Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Later this evening my mother was with my sister in METRO Cash & Cary...Then my phone ring!!! She told me that the right xenon light is not working,before that enterior lights not working,as she was parked agains glass she saw in glass that boot lights are NOT working! Then about 20-30min ago I went to garage to see what and where is the problem!!!

1st) Left xenon light is working,right,NO! I changed D1S Bulbs Right>Left,Left<Right and then the right side that didnt glow wasnt glowing again,although I changed places of bulbs both bulbs are OK! Then I checked fuses box and relays,every single one of them are ok! Have no Idea what is the problem!!!???

2nd) I opend drivers door,...,lights? Nothing happens,no glowing enterior,DARK!!! Again I have checked all fuses and relays,again every single one of them are OK,no problem!!!???

3rd) I put key to MAR (Contact) put in reverse rear lights WORKING,rear foog lights WORKING,rear stop lights NOT WORKING! Although the rear stop lights are working! I have checked connection at boot doors,everything OK!!! BUT NOTHING WAS WORKING!!!

Please tell me WHAT and WHERE to LOOK!!! This car is starting to **** me off,It is like a NEW,almost smels like new,passed 70000km,service book ok!!!

1st) Xenon problem...Where is the ballast? What to look else,except fuses and relays????

2nd) What could be the problem of enterior lights except fuses and relays????

3rd) ...You know...PROBLEM>>>???<<<

Please help me...It is like I am driveing this car not my mother! Because for every singl problem she calls me and BUGS me...GUYS???HELP!!!

Thank you in advice!!! :confused: :confused: :confused: :rant: :rant: :rant:
 

·
Registered
Joined
·
122 Posts
Must be a relay that controls all three things - i have a bad relay, which as my electrician said controls inner boot light, back fog lamps, and boot check control light on the dash. My is scheduled for repair next week...:cool:
 
1 - 2 of 2 Posts
Top