Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
Hi all, got my bella back today (at last, if i had to drive that Corsa for another day....).

Anyhow, new sump fitted, obviously fresh oil and filter and had crank sensor done at the same time, this picture tells it all about the last garage that changed the sensor.

Cowboys!
 

Attachments

·
Registered
Joined
·
134 Posts
Discussion Starter #3
I will have to double check through the history folder when i get home so don't hold me to this, but i am sure the last recorded sensor change was done by an Alfa specialist, not in the North East i hasten to add, but before i accuse i will recheck.
 

·
Registered
Joined
·
134 Posts
Discussion Starter #5
I wasn't amused, i have to admit. I am thinking about writing to them including the photo. Maybe i can get the cost of a new sensor back from them. As if......

:rolleyes:
 
M

·
Guest
Joined
·
0 Posts
Do name and shame and pull one of the wires out and ring them and complain that your car is stuck on the side of the road as Butchers annoy me big time:(
 

·
Registered
Joined
·
134 Posts
Discussion Starter #12
Seems like having the crank sensor replaced has solved numerous problems, wondering if my connection was arcing as it seems to have solved some electrical problems?

Firstly it was obviously where my oil leak was from, drive is nice and dry and free from oil now :)

Secondly, i now no longer get an error beep from the alarm? It sets as it should.

Thirdly, no more dicky central locking?

Don't know if this is all coincidental but it seems not.
 

·
Registered
Joined
·
4,646 Posts
well, who did this work?
 
M

·
Guest
Joined
·
0 Posts
Well what a butcher what do we do these untrained and unqualified mechanics....
 

·
Registered
Joined
·
134 Posts
Discussion Starter #16
According to the history i have it was changed by an Alfa Specialist in the North West a couple of years ago.
 
1 - 16 of 16 Posts
Top