Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
G stopped at the traffic lights on stop start and wouldn't restart. Got towed home & Since this we have taken the starter motor off - which works fine.
We then found an incorrect battery had been fitted by a previous owner so we have changed this for a correct stop start battery & still the G won't start.

Does anyone have any ideas/ suggestions/ experiences with the G that might help us get her restarted please!
 

·
Registered
Joined
·
257 Posts
When you say 'it won't start' do you mean it's turning over and won't fire or it's not turning over? I assume the latter otherwise you wouldn't have taken the starter motor out.
If it's not turning over, it could be a broken earth strap although I'm not sure where it is. It has been mentioned on this forum before.
 

·
Registered
Joined
·
1,005 Posts
I am having some work done on my car (limp mode plus got rear ended....)

He discovered that a marten (big rat) chewed the cable to the blow off valve actuator, and did major damage to the earth strap. One more bite and it would have been through.....
BTW you can only see it with the under-tray removed......
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
When you say 'it won't start' do you mean it's turning over and won't fire or it's not turning over? I assume the latter otherwise you wouldn't have taken the starter motor out.
If it's not turning over, it could be a broken earth strap although I'm not sure where it is. It has been mentioned on this forum before.
We have a winner - after a new battery, starter motor on & off - it turned out to be a broken earth strap to the gearbox! Bugger had broken inside the plastic casing - unbelievable!

Thanks for all the help guys
 
1 - 6 of 6 Posts
Top