Alfa Romeo Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Hi,

Some clown smashed my passenger side elctric wing mirror. Fortunately I think I can fix it ... spring is gone, hopefully just needs re-setting and the wire for folding mechanism is cut ... should be a simple fix ... however only if I can get the thing off ??

Does anybody know where the cables un-clip or unhook?? Is there a connector inside the door panel and/or where is it? way down in the door or up near the mirror ??? I don't want to go pulling too hard on the already fragile cable until I know a connector is going to show up? ?
 

·
Registered
Joined
·
100 Posts
Discussion Starter #7
Thanks, but the squabbling about 155 models is not very helpful to me. Thanks zulu for trying to answer my query...............
 

·
Registered
Joined
·
6,300 Posts
you do need to take the door panel off - i battled for hours trying to get the mirror off without taking the panel off but gave up in the end.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #10
Thanks for that Niall. There must be a very long cable before the connector then ? I just hate taking the door panel off as it never quite fits back as securely i.e. rattles !!!!!!!
 

·
Registered
Joined
·
6,300 Posts
ummm - can't remember to be honest...all i can remember was that i could get the bloody thing off without taking the panel off :(
 

·
Registered
Joined
·
6,300 Posts
good luck with it! i couldn't figure out the door panel at all....the 166 panel is easy peasy in comparison....
 

·
Registered
Joined
·
42,287 Posts
Now Demon, vague recollections coming back, on the Thema of course, so not a 164. Only trying to remember, so probably totally wrong, but, feed leads threaded through that convoluted rubber tube/door through to A post, then panel off in the footwell, scrabble about in the sheet metal for the connector? Probably absolutely wong again, someone will jog my memory a bit more accurately.Can't really remember if I am honest.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #16
Thanks guys. PeteH ..that's just what I was looking for cheers. if I accidently discover any easy way (some chance) I'll post it.
Wrinx...... apologies for the ill temper, lesson learned never post on a laptop while skinning your knuckles on a door liner !!!!
It's been seven years of Saabs before returning to the Alfa's ...etc .etc..
 

·
Registered
Joined
·
100 Posts
Discussion Starter #19
1996 2L ts ...97k on clock, good clean car generally, however I'll soon get the truth as it's in today for a service with a well respected Alfa man. However he didn't pull any faces when he saw it. Funnily enough having spent months trying to track one down there was a tidy '93 up on the ramp too !! Was going to get a 166 but thought I'd at least have a little 164 experience before they all turn to dust .....
 
1 - 20 of 21 Posts
Top