Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
7,154 Posts
Discussion Starter #1
Whenever I borrow someone's car (courtesy car, Dad's car, Mum's car, hire car, work pool car all of them apart from my wife's), I'm always amazed at how silent the wipers are. I've always wanted a car with silent wipers and I've only ever had it for a couple of months after fitting new Bosch blades to my car and then it goes again.

Anyway I was really pleased with the GTA as I finally owned a car with silent wipers, until this morning, after a month in my possession, it realised it belonged to me and I'm not allowed to have silent wipers, so it started making a juddering noise.

Why me? I'm so anal about making sure they're only used when the windscreen's got a bit of moisture on it as I so want to have quiet wipers. :rant::rant::rant::rant::rant:
 

·
Registered
Joined
·
7,154 Posts
Discussion Starter #3
have you tried rain x apparently that helps
Have heard of it, probably worth a try. I just don't understand why it's only me that seems to suffer from this problem though.
 
V

·
Guest
Joined
·
0 Posts
weird, do you use some sort of screen wash thats different to everyone else or something???
 

·
Registered
Joined
·
44,882 Posts
Have heard of it, probably worth a try. I just don't understand why it's only me that seems to suffer from this problem though.
The very cold weather probably affected them, a friend of mine is replacing their wipers after only 6 months because they are making so much noise. It started after the freezing snowy stuff.
 

·
Premium Member
Joined
·
19,119 Posts
I've never had it on any of my cars but my girlfriends has it. And I can tell you why too. Its cos you probably use em when the screen is too dry. Honestly I know this cos her 206 has an intermitent setting that uses a sensor on the screen to tell it when there is water on it and it goes off a lot quicker than I would normally set the wipers. And suprise suprise it only make the noise when the sensor is in control. I know this sounds odd but trust me, I'm def not doing anything stupid like driving in terential rain on the intermitent setting on or something. Well thats what I recon anyway.
 
N

·
Guest
Joined
·
0 Posts
Don't use rain-X. Once you put it on it'll never come off
and doesn't really work that well with wipers

Good for SkyView/Sunroofs/Side Windows/Wing Mirrors etc though. :thumbs:
(Any glass surface that doesn't have wipers. ;))
 

·
Registered
Joined
·
7,154 Posts
Discussion Starter #8
And I can tell you why too. Its cos you probably use em when the screen is too dry.
Like I said in my first post, I'm obsessive about making sure the screens not dry. I wait until I can't see through the windscreen, then wait a bit more before I wipe!
 

·
Premium Member
Joined
·
19,119 Posts
Must be God having a laugh with you. Cursed I tell you, CURSED!!!:lol: Have you thought about fitting aero blades? They are much better than the standard items.
 

·
Registered
Joined
·
4,932 Posts
Cheap wipers? My family's cars all have noisey wipers apart from my own. The difference is that i use expensive wipers (was bosch spoilers, now Valeo aero style) and they never make any noise. My family all use the cheap blades you get in aldi/asda.
 

·
Registered
Joined
·
1,172 Posts
I had cheap wipers off e-bay worked a treat but give up when the ice turned up! Thought I'd splash out on some Bosch ones about £30 a pair! Load of rubbish they miss a section right in front of my eyeline! I'm sticking to cheap ones in the future!
I was recomended them on here too, from wiperblades.co.uk
 

·
Registered
Joined
·
6,811 Posts
Don't use rain-X. Once you put it on it'll never come off
and doesn't really work that well with wipers

Good for SkyView/Sunroofs/Side Windows/Wing Mirrors etc though. :thumbs:
(Any glass surface that doesn't have wipers. ;))
iv never had issues with it:confused:, works a treat for me:D
 

·
Registered
Joined
·
7,154 Posts
Discussion Starter #13
Cheap wipers?
I've always used the bosch ones. Find them fine at first, but then start making a noise after 3 months. I don't know what are on there at the moment, but I'm going to try aerotwins. Reckon I am cursed though. Especially as the clutch has gone the day after the blades started kicking off!
 

·
Registered
Joined
·
316 Posts
I bought a set of Goodyear blades for my van about 6 months ago. Cost me about £13.00 for the pair from Costco. I was amazed how silent they were when I fitted them and they still are now. I can't stand anything on my windscreen so I use them a lot (never dry though). Funny looking things. There is no metal frame, the reinforcment is moulded into the rubber. When you lift the wiper arm to wash the windscreen, they almost bend to a u shape. They work really well and I'll be using them on all my cars in future.
 
1 - 18 of 18 Posts
Top