Alfa Romeo Forum banner

1 - 6 of 6 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi to all have tried to see if anyone has had this before is there any reson why the wipers only occasionally make it all the way across the screen. I have tried different settings on wiper controls but just can't see what triggers full wipes.
Regards to all and happy new year
 

·
Registered
Joined
·
1,271 Posts
Ive had it where the wipers played up the would not work then would not turn off.Relay n14 fitted on the side of the fuse box filled up with water!
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #6 (Edited)
Thanks all for your ideas here as follows is what fixed it

Hi to all I finally got bored yesterday and removed the entire wiper mechanism.
You should be able to undo the main arm of the motor spindle put a mark on the spindle to line up with the arm forwhen you re assemble.
So once the arm is disconnected remove the three bolts holding the motor to the wiper mech frame pull the round black plastic shim of the spindle then the rain cover will come off.
Rite this is where you have to remove the three self tappers that hold the control unit in place.
Once removed a soldering iron will be needed to unsolder the three joints then the control unit will come free. You will now be able to see the brass track on the main gear in the motor thru the cutout remove the four bolts remove the plate and gasket you can now see the main gear fully. You may want to also mark this if you want prior to removal. Push the spindle slowly the nut side to remove the gear and thoroughly clean the brass track I used an old fashioned pencil eraser one of those gritty ones and also a fibreglass pencil to clean up the surface.
Then put a fine smear of grease on the spindle and return back to the motor don't worry about the two smaller gears as these don't need timing.
Now the control unit does come apart with a wide ruler work your way around the unit and it will unclip you will notice that there is A type of glue that is like Evo stick that will just fall off.
Once the cover is off pay at tension to the three soldered joints where the three contacts come thru the plastic unit and join the board the one closest to the edge of the unit had a crack
In the solder.
So again use the soldering iron to make the joint good again.
Now the cover can be clicked back on.
Clean up the three contacts and make sure they are running in line with the recess they sit in and then set about re assembly I would leave the three soldered joints till last job.
My wiper now does full wipe time and time again not when it feels like it due to the dodge joint.
You could just do the joint if you wanted but I stripped it all down and regressed the motor too.
Hope this helps somebody else out
Should have taken some photos really but Heinsight a lovely thing
 
1 - 6 of 6 Posts
Top