Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
435 Posts
Discussion Starter #1 (Edited)
Ok, the fan went in the car last week and I played around with fuses etc. It was blowing the 30A fuse on top of the pollen filter. Read a good few posts here over the weekend and was going to attack the fan and see if thats where the problem lay, but after a bit more reading, it seems that people who even replaced the fan still had the problem

So, I went to my local auto electric guys and spoke to them about putting in a 40A fuse and other things, but they advised against this unless I'd like the risk of causing a burnout in the car!! I left the car into him this morning and have just been back with him. Basically he has spent a few hours trying to find his way around the 166 and has no workshop manuals for it. Every manual he has, all have the 156, GTV etc listed but no entry for the 166.

At this stage he has gone through fuses, relays etc and the feed from the 30A fuse is going back into the dash and he is assuming there is an ECU for the climate control, but has no idea where to attack. I said I'd post here and find out what I could and hopefully save him time (me money!) when he continues tomorrow!!

I have seen a few mentions of the ECU being behind the ICS and some saying its underneath it? Does anybody know exactly where its located? Also, I'm off to search now for how to remove the ICS unit, but if any of you have any tips or links, please do feel free :lol:


****JUST FOUND THE ICS REMOVAL THREAD, SO AT LEAST THATS OUT OF THE WAY****
 

·
Registered
Joined
·
12,881 Posts

·
Registered
Joined
·
3,336 Posts
Let us know how it works out... :thumbs:
 

·
Registered
Joined
·
435 Posts
Discussion Starter #5
Hi Ronald. He got to have a look at it today and has traced it to the fan, so he is more or less sure its the fan itself that is gone, or else a damaged wire in there (which is doubtful), so he has to degas the aircon and take it out in the morning, so I will know the full story then
 

·
Registered
Joined
·
435 Posts
Discussion Starter #6
OK. The motor in the fan has gone, so I am looking for one.....

From what I can see, the part number is 77362655. Can anybody point me in the right direction?
Looking for new preferably as these things seem to go at about 100k, so with the job to take it out and put it back in, I dont fancy doing it again soon!!

http://www.alfaowner.com/Forum/attac...number-fan.jpg

Priced one here and its €277+VAT (€335/£265)
From posts I have seen on here, UK dealers seem to supply it at around £125! Thats half what I have been quoted!

Any help much appreciated.
Thanks guys :thumbs:
 

·
Registered
Joined
·
7,120 Posts
try Desira in Diss, Suffolk on 01379 650131 (UK no, not sure what else you have to add) they do a very good postal service.

HTH
 

·
Registered
Joined
·
435 Posts
Discussion Starter #8
Cheers for that. Just spoke to Roy there who was very helpful and I have ordered the part. Only thing I forgot is you guys have bank holiday this weekend (we have it at beginning of August), so it might add a bit of time to the delivery, but at least its ordered now anyway ;)
 

·
Registered
Joined
·
7,120 Posts
Cheers for that. Just spoke to Roy there who was very helpful and I have ordered the part. Only thing I forgot is you guys have bank holiday this weekend (we have it at beginning of August), so it might add a bit of time to the delivery, but at least its ordered now anyway ;)

Roy is the parts manager or supervisor there, he is indeed a top bloke and never, ever has failed to come up with the goods so far.

Good that you got sorted.
 

·
Registered
Joined
·
435 Posts
Discussion Starter #10
Finally all sorted! Part arrived last week on Friday morning as the bank holiday held up delivery. Guy put it back this morning and have just collected the car and all is well :)

Collecting new pollen filter in the morning and recharging the aircon ;)
 
1 - 10 of 10 Posts
Top