Alfa Romeo Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
500 Posts
Discussion Starter #1
I pulled out from a petrol station this afternoon and all was fine, had to stop at a set of traffic lights for few minutes and when I decided to pull off there were no gears. I could not select ant forward gears, selected reverse and the car was moving back slowly even though the clutch was down to the floor, I let the clutch go with the handbreak on and the car stalled.

Started the engine again and all was well, I stopped on few traffic lights after and then drove back home nearly 70 miles and still everything was fine.

Has anyone else ever experienced this, i have heard of the cables getting snapped or the linkage breaking but mine happened for about 5 mins and then is ok now.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #3
sounds like it could be your slave cylinder. It wontr be long now until it totall fails if it is. Check the fluid level.
Thanks for the quick reply,

I got the ARB bushes changed on Monday at a local garrage, could it be when any kind of damage might have happen ??
 

·
Registered
Joined
·
1,271 Posts
One of the springs within the clutch centre plate may have broken and then lodged in the clutch causing no gears. The part then drops off so the fault goes untill eventually another part of the spring comes out and gets lodged on the centre plate. Happened to me over a two year period on a spider i drove 3k a year.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #6
I doubt it. Have you checked the fluid level? Is yours a manual gearbox?
Yes it is a manual gear box. I checked the fluid and its upto the mark.
drove 40 mile round trip to work today and no problems however this has really made me curious LOL .
 

·
Registered
Joined
·
500 Posts
Discussion Starter #7
One of the springs within the clutch centre plate may have broken and then lodged in the clutch causing no gears. The part then drops off so the fault goes untill eventually another part of the spring comes out and gets lodged on the centre plate. Happened to me over a two year period on a spider i drove 3k a year.
Whats the fix and will I have to rob the bank to get it sorted or shall I keep driving it for as long as I can and hope for the best?
 

·
Registered
Joined
·
551 Posts
Changing out the slave cylinder was sound advice, I'd start with that.

I say that as something very similar happened to my 147 when she who must be obeyed was driving it (sods law :rolleyes: ) and after a few miles of difficult gear selection and the clutch going to the floor the slave cylinder (essentially) 'detonated' putting fluid everywhere. Which was nice.

So, get the slave cylinder checked out and/or replaced :thumbs:
 

·
Registered
Joined
·
1,134 Posts
shall I keep driving it for as long as I can and hope for the best?
TBH that is normally the more expensive way of doing things, dont forget when/if it goes it wont be on your drive when you have some spair time and cash it will be in traffic when your late and just after paying for wedding/c heating/yearly tax bill ect :p
 

·
Registered
Joined
·
500 Posts
Discussion Starter #10
TBH that is normally the more expensive way of doing things, dont forget when/if it goes it wont be on your drive when you have some spair time and cash it will be in traffic when your late and just after paying for wedding/c heating/yearly tax bill ect :p
Well TBH its not really my thing LOL so its getting looked at tomorrow morning and hopefully it will be sorted soon and won't cost me my sleep .
 
M

·
Guest
Joined
·
0 Posts
To replace the slave on these the box has to come out doesn't it ?
It's not really a cheap and easy fix as seems to be suggested :?
 

·
Registered
Joined
·
500 Posts
Discussion Starter #13
Just got back from work and there was a message on the phone from the garrage, he says I need a 3 piece clutch kit and quoted me £ 200 for the parts. Is that good ?Thanks for all the help guys..
 

·
Registered
Joined
·
500 Posts
Discussion Starter #14
So far in last 6 months its had 2 lower wishbones, 2 upper wishbones (TRW)2 drop links(TRW) ARB poly bushes,1 lambda sensor,4 bridgestone tyres,2 white sidelight bulbs and now this clutch :cry::rant: .
Just don't know when is it goint to stop .
 

·
Registered
Joined
·
9,912 Posts
Just got back from work and there was a message on the phone from the garrage, he says I need a 3 piece clutch kit and quoted me £ 200 for the parts. Is that good ?Thanks for all the help guys..
if they supply parts labour charge maybe low but if you do they might lift labour charge to suit their profit margin
 

·
Registered
Joined
·
500 Posts
Discussion Starter #17
if they supply parts labour charge maybe low but if you do they might lift labour charge to suit their profit margin
Well if you think the price is right for the parts then I will let them get the parts, he charges 35/hour plus VAT and I think thats quite reasonable. how long do u think it will take to do the job ? Will have to use the plastic money again.
 

·
Registered
Joined
·
9,912 Posts
Well if you think the price is right for the parts then I will let them get the parts, he charges 35/hour plus VAT and I think thats quite reasonable. how long do u think it will take to do the job ? Will have to use the plastic money again.
IMHO if they supply parts and if anything failed it would save hassle of claiming against either party :thumbs:
 
1 - 20 of 31 Posts
Top