Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
Today my car has developed an awful noise. When I put it in reverse it makes a noise like rusty bits being shaken in a can! It only does it when cold or stood for a few hours. It goes after about half a mile or less driving and then won't do it untill it's cooled down again. My car has a Q2 fitted but the clutch is VERY heavy. Also there is a drone noise which I thought was a rear wheel bearing. Most noticable at 20mph. I'm wondering if this is related now?

Got my car booked into A&M alfas begining of feb to do the clutch and other things but am worried something is going to blow! Does anyone have any idea what it might be?

Ment to say it only does it in reverse and only on initial pull away, once moving it stops.

Cheers.
 

·
Registered
Joined
·
1,309 Posts
Try parking with handbrake off and in gear.

May be pads dragging in reverse?
 

·
Registered
Joined
·
2,247 Posts
Sounds like exhaust maybe? I had a similar noise when hitting bumps after I'd had a few jobs done on her and once she was warm the noise disappeared.... worth a look ;)
 

·
Registered
Joined
·
1,309 Posts
Sounds like g box...
 

·
Registered
Joined
·
2,247 Posts
I'd just had my gearbox done when the noise happened on mine and was pooing myself! :eek:
Was defo the exhaust tho... like I said, worth a look :thumbs:
 

·
Registered
Joined
·
150 Posts
Discussion Starter #8
I'd just had my gearbox done when the noise happened on mine and was pooing myself! :eek:
Was defo the exhaust tho... like I said, worth a look :thumbs:
I wish it was but I don't think it is. Only does it when slipping the clutch in reverse and my clutch is mega heavy. Possibly the clutch is disintergrating? All I know is it sounds bloody expensive :cry:
 

·
Registered
Joined
·
2,247 Posts
I wish it was but I don't think it is. Only does it when slipping the clutch in reverse and my clutch is mega heavy. Possibly the clutch is disintergrating? All I know is it sounds bloody expensive :cry:
Unlucky :( Hope you get it sorted soon.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #10
Well, as suddenly as the noise came it has now gone! Moved and changed slightly is more accurate. It seems you may have been right Alfa Moo. There is a similar noise coming from the back box when cold. Not as loud but it's there. Luckily one of the jobs being done at the begining of Feb is a new Supersprint exhaust!

Thanks to all above for your comments and suggestions:thumbs:
 
1 - 11 of 11 Posts
Top