Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
after getting overly excited about finally getting my turbo removed I broke this :( can anyone tell me exactly what it is and the best place to get one? I broke the 2 plastic connectors the pipes connect too.... one of them is to the turbo
 

Attachments

·
Registered
Joined
·
41 Posts
Discussion Starter #4
the one from autolusso on ebay doesn't state any part numbers, the other one does but its a different number to whats on mine and states that it wont fit if diffrerent (looks the same) is that just to cover his back??


the numbers on mine are:

46768250
7.21903.11
 

·
Registered
Joined
·
1,375 Posts
just get the part number off it and search on ebay. It's not an item which commonly breaks, except by cack handedness by people like you and me (i broke mine as well :)), so getting a 2nd hand one is fine.

[email protected]
 

·
Registered
Joined
·
38 Posts
Get yourself some alcohol based solution and clean it off, get something strong like a superglue and glue the pipes back on so long until you can buy a new one. Here in South Africa we get the Q-Bond glue with powders, I fixed loads of boost controllers that guys broke each time I get turbo cars in, they can be repair as a temp measure and last as long as a new one. a good glue, a few minutes with a steady hand and you'll have it sorted.
 

·
Registered
Joined
·
544 Posts
does this fail? could it be the cause of my slow pickup? Im replacing the hoses this weekend
 

·
Registered
Joined
·
38 Posts
does this fail? could it be the cause of my slow pickup? Im replacing the hoses this weekend
it does fail yes. but slow pickup could be caused by VNT's being stuck.

Easy way to check is to strip down to the point where you can see the turbo. get some vacuum on the line directly to the line that sits on the VNT actuator, or if you can, push and pull against the rod. if it does not move it means the vanes are stuck. It is easy to strip down and clean them if you know how, but I have heard about some stuff you can spray in that removes all the build up around them. Where I live we do not get this spray and I have loads of turbo knowledge so I just strip them down and clean them.

If however you experience this due to the vanes being stuck, it usually comes with a underboost/overboost error aswell.

So I suggest you rather diagnose each bit before stripping it down. Check vaccum lines, turbo play, the actuator movement as mentioned and even boost leaks and also EGR if it is JTD, JTS afaik does not have EGR.
 

·
Registered
Joined
·
147 Posts
the one from autolusso on ebay doesn't state any part numbers, the other one does but its a different number to whats on mine and states that it wont fit if diffrerent (looks the same) is that just to cover his back??


the numbers on mine are:

46768250
7.21903.11
Ah sorry mines 16valve got it of them last week, but now looks like my turbo is Fooked just making contact so not as bad as your pics, you said you could only find 16v turbos? were did you see them as there ar a few different ones, also ebay seems to have a few 8v ones thanks.
 
1 - 12 of 12 Posts
Top