Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Mito Cloverleaf 2010
Joined
·
7 Posts
Discussion Starter #1
Anyone tell me if I'm missing something from the dash slot. That stereo wasn't located properly and slipped straight out and the blue and me box is just sitting there, flapping around. I'm thinking there should be some kind of bracket, held in place by those screw holes.

949283
 

·
Registered
Mito 1.4 8v 2010
Joined
·
18 Posts
Yeah, your missing the metal cage that holds the head unit. The original head unit uses a single din cage but you can fit a double din cage and matching size aftermarket head unit. I fitted a mounting kit from connects2 like picture attached.
What radio unit do you have that just fell out?


Sent from my SM-G781B using Tapatalk
 

·
Registered
Mito Cloverleaf 2010
Joined
·
7 Posts
Discussion Starter #3
It's the factory head unit, single din with the facia all attached. I'm thinking the previous owner had a double din aftermarket head unit with suitable cage, removed it to pass the car on and never fitted the original cage back in and just stuffed the original head unit in the slot. It didn't even have the wiring connected.

Presumably the original cage has as single din slot and then underneath somewhere for the blue and me box to attach to?
 

·
Registered
Mito 1.4 8v 2010
Joined
·
18 Posts
It's just a standard single din cage I seem to remember and the clips on the side of the stereo will latch into the cage when push back. You could even try this with a new cage before fitting. Don't worry about the blue and me unit. It would just sit where it is now if you fitted a double din HU.
Halfords sell single and double din cages. Jus a thought though, if the radio wasn't wired in and you have no idea what the security code is, you won't get it working anyway.

I've got the bits that came out of our Mito in the loft. Could photograph for you tomoz if you want.

Sent from my SM-G781B using Tapatalk
 

·
Registered
Mito Cloverleaf 2010
Joined
·
7 Posts
Discussion Starter #5
Thanks @Byngo69 , don't go to any trouble though, I think I get whats missing now.
I'm thinking as this was the original head unit the bcm will know about it and have the code saved, but yes you're right I don't have the security code.
 
1 - 6 of 6 Posts
Top