Alfa Romeo Forum banner

41 - 60 of 2188 Posts

·
Registered
Joined
·
4,779 Posts
Discussion Starter #41
D brings up turbo boost. A gives digital speedo.

Does it come up immediately? I just seem to get the usual screens


Any spelling/ grammatical errors are purely there to annoy!
 

·
Registered
Joined
·
554 Posts
i have had today these special badge details added to the car. It is a take on the Alfa 60th Giulietta Anniversary shown on their Italian website. Wing ones are in black whereas the one on the boot is in silver as the glass is very dark and if fitted from the inside would not be seen as easily. Measured to ensure the sweep of the wiper arm does not come in contact with the badge. Wheel centres, grill and boot badges swapped for black and silver versions to keep the theme.
 

·
Administrator
Joined
·
87,300 Posts

·
Registered
Joined
·
27 Posts
Screwed new holes in new number plate to make the front number plate curve to the body shape and not stick out as it had been.
 

·
Registered
Joined
·
554 Posts
Well I thought it would get the ball rolling!! Graphic work was done and fitted by a local car / van graphic sign company who thought it looked very good. I supplied the idea / concept and they did the artwork.
 

·
Premium Member
Joined
·
5,374 Posts
I've driven mine to work - and back today. It's not enough!!
 
T

·
Guest
Joined
·
0 Posts
Does it come up immediately? I just seem to get the usual screens


Any spelling/ grammatical errors are purely there to annoy!
Cycle through the screens using the button on the end of the right stalk whilst in Dynamic mode and you should eventually come to the boost gauge.
 

·
Registered
Joined
·
4,779 Posts
Discussion Starter #50

·
Registered
Joined
·
5,026 Posts
Updated Blue & me this morning not sure what difference it has made....
 

·
Registered
Joined
·
708 Posts
T

·
Guest
Joined
·
0 Posts
Turn your radio off and try again. If it works then go into the dash menu, find an option called 'radio repeat' pr something similar and turn it off.
I couldn't find that 'radio repeat' when I checked. It just started to work when I cycled through the menus.
 

·
Registered
Joined
·
4,779 Posts
Discussion Starter #55
Turn your radio off and try again. If it works then go into the dash menu, find an option called 'radio repeat' pr something similar and turn it off.

Thanks, that's exactly what the thread I linked to suggested, so now have the turbo gauge, seems to got to 100% unlike others here ( or my 159!


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
5,026 Posts
Fitted some lovely QV style badges to the ol' girl today during the 10 minutes of sun we had...
 

·
Registered
Joined
·
945 Posts
Well it seems like in a year I'm putting about 14k on the clock (I do long journeys just the cars not being used everyday) so on that basis the car will be about 9 year old before its reaching your current figures :p
 
41 - 60 of 2188 Posts
Top