Alfa Romeo Forum banner
1 - 20 of 24 Posts

· Registered
Joined
·
84 Posts
Race mode install done. Just because.... :LOL: Will be getting the car remapped with some possible hardware changes. its only a 2.2 JTD with 130bhp from factory so hopefully will get it to 260BHP with a torque gain of at least 150Nm when complete. Coding didnt work when I selected Type 3 for the dial. It defaulted back to Type 1. Recoded to Type 2 and it worked. I cant tell if the traction control actually goes off or if it disables the collision warning but gear changes are now at almost 4500 rpm when you floor it.. Going to do a comparison when gear changes occurs in other modes.

Car Vehicle White Plant Automotive design

Speedometer Car Automotive design Gauge Tachometer

Car Vehicle Automotive tail & brake light Automotive lighting Hood
 

· Registered
Joined
·
84 Posts
Hmmm... Discs without anti-rust coating? They are not going to look nice after a couple of washes... Or are you planing to coat them with high-temp paint?
Mines no QV so not really fussed. Cant be any worse than the standard discs. I do use the car everyday of the week so that should hopefully keep the rust away.
 

· Registered
Joined
·
84 Posts
Seem to be nice.
How are working? They produce noise?
Can you share amazon's link?
They work fine. there is no noise from them when not used but I have put some foam tape where they touch the metal when folded.

 

· Registered
Joined
·
84 Posts
Fitted a TDI tuning box, still under warranty so don't want to to go full ECU tune yet.

Purchased from forum member last week.

Initial thoughts after 40mile run in on level 4 then set to max level 7, it pulls hard!

However it's made the throttle lag more noticeable as when I plant it, just like usual, it does nothing for a second then there's the bolt of acceleration.

Overall pleased so far with it just wish the throttle lag was better. It's actually pretty annoying, particularly when breaking hard at a corner or roundabout then pressing accelerator to end up just coasting around the corner whilst the car decides to give me some power.
Cant do much about throttle lag, can be minimised with a good remap but cant be eliminated. Have had a few Tdi's remapped with Darkside Development and they all had the same issue. The bigger the turbo, the bigger the lag as the spooling time is higher. The only solution which almost eliminates turbo lag I believe - is a E-turbo that houses a electric motor. However this seems to only be available on some AMG cars. The other option that sort of worked on my TT was to let the engine idle at a higher speed. It minimises the lag. But love a remapped Tdi. Im a bit odd that way. 😂
 

· Registered
Joined
·
84 Posts
Because I'm just a massive child at heart, I took the opportunity to install Race mode when I needed to change the Radio on/off switch. Totally necessary... :unsure:

Test drive in wet conditions has convinced me never to use it when it's not dry! :oops:

View attachment 980610
Do your paddle shifters work in race mode? Only asking becauseI retrofitted both - race mode and paddles and paddles dont work in race mode.
 

· Registered
Joined
·
84 Posts
Yes, the paddles shifters work in race mode. Mine is a Veloce so they were factory fitted. Weird that they would work in every other mode? Which type of DNA switch did you select in MES? I selected type 2, but there was a type 3. Not sure what the difference is.
Type 2. Type 3 just didn't work and none of the errors would go away. Infact the car would be completely crippled and would not even go into drive using a type 3. I read somewhere that there is a difference in the d-n-a selectors depending on the year it was made. maybe that has something to do with it.
 

· Registered
Joined
·
84 Posts
Park facing uphill, then open the boot and watch the lid flail gracefully back and forth rather than open fully.

Three ways of dealing with it...
1. Zip tie a few of the spring coils together to create additional tension.
2. Buy an upgraded set of springs/bump stops.
3. Park facing downhill :LOL:
😀

I did have an issue with my boot lid when I got the car but that was down to a faulty damper which I believe was on the LHS of the boot. The dealer did replace this for free. Well he took it off another Giulia and put it on mine I later learned. Not tried parking uphill and opening the boot. Something to think about when the opportunity arises.
 

· Registered
Joined
·
84 Posts
Done a steering wheel swap with one from a Veloce. Surprisingly was a straight swap. Must say that for someone with large hands, it does feel a lot more comfortable than the standard steering wheel. Shame I wont be able to get the heated steering working - would have been a bonus in this weather. Now for the all important go faster red start button. :rolleyes:

Vehicle Motor vehicle Car Speedometer Steering part
 

· Registered
Joined
·
84 Posts
Have the left hand buttons configured ok given that there are differences between the steering wheels on the MY20 and earlier models?


Sent from my iPhone using Tapatalk
Didnt have to configure anything. All the buttons worked just as before except for the one in the circle below which I dont know what it does on other cars.

Car Vehicle Automotive design Plant Motor vehicle
 
1 - 20 of 24 Posts
Top