Alfa Romeo Forum banner
1 - 11 of 11 Posts

· Premium Member
Joined
·
43,207 Posts
Recently passed the 16K mile mark in 18 months ownership. I think I'm about 3.5k miles down due to covid lock downs and spells working at home.
 

· Premium Member
Joined
·
43,207 Posts
Last week I reversed into a very low wall that was out of my (mirrors) sight after thinking I knew better than my parking sensors :rolleyes:
which will cost me £250 ish to get repaired later this month 😤
 

· Premium Member
Joined
·
43,207 Posts
I took my Giulia to the body repair shop this morning having thought I knew better than the rear parking sensors :rolleyes:
Turns out it's actually due in tomorrow .... so I'll be back again in the morning 😅 numpty springs to mind
 

· Premium Member
Joined
·
43,207 Posts
19 inch 5 hole standard alloy not diamond cut as in my profile pic. Had them refurbed through an insurance policy I took out when buying the car. The company that did the work is called revive

www.revive-uk.com

Looks a decent job (y)
 

· Premium Member
Joined
·
43,207 Posts
Sent her in for the first MOT this morning.
The worrying thing this morning was the two error messages displayed about 500 yards down the road first thing. No stop/start and check parking brake :oops:
The parking brake wasn't working and holding the car and the light on the switch didn't elluminate.

The hand brake red symbol was constantly flashing for the first 14 miles. Had to stop to fill up. Then error messages didn't reappear and the parking brake was working again.

My thoughts are low charge from the battery maybe?

Anyway, she passed the MOT (y)
 
1 - 11 of 11 Posts
Top