Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,226 Posts
Discussion Starter #1 (Edited)
Some time back I bought a W reg 156 non runner in quite good order. Black with light grey interior, lowish mileage and service history.
I got it going and it runs very nicely, got an MOT but it had a problem with the ABS system.
For various reasons the car was laid up and the MOT has run out, the ABS problem is still there and I noticed that the Air bag light is now on. So the question is, do I break her or just weigh her in. I will take the wheels and tyres off as they are good and will fit my other 156 and I have some spares that my be worth selling separately ie ECU's.
So do I try to sell her as a project, break her or just weigh her in. It must go as I now need the garage space.
Thoughts please.
Oh, and any ideas as to value.
 

·
Registered
Joined
·
1,226 Posts
Discussion Starter #4
Rockhopper, thats pretty much what I thought.
Biffa, Yes I did some time back but as I recall it did not show any issues, strange.
The air bag showed internal problem as I recall.
 

·
Registered
Joined
·
5 Posts
the conections to the airbag under the passenger or drivers seat have a tendency to be a little wobbly, i recently fixed this on my 147 and the warning light is now gone. i had an ABS failure too, but that occured after i took a handbrake slide, just reset the computer and everything is fine. just left with the Motor Controll System Failure now..... which i guess is either a burnt valve or a faulty coil somewhere as i lose power when i pass 4000rpm.

best of luck!
 

·
Registered
Joined
·
13,685 Posts
Hi Phil,
My GT had a similar problem. Undid the connector under the passenger seat an used WD40. Not lit since.
I have a bluetooth OBDII connector and the Fiat Diag stuff on my laptop if it is any help. Be good to see you again Phil :)
 

·
Registered
Joined
·
1,226 Posts
Discussion Starter #7
Hi Phil,
My GT had a similar problem. Undid the connector under the passenger seat an used WD40. Not lit since.
I have a bluetooth OBDII connector and the Fiat Diag stuff on my laptop if it is any help. Be good to see you again Phil :)
Hi Malc, nice to hear from you, are you enjoying your GT?
Thanks for the offer, I have a OBDII connector, not as snazzy as yours, mine has a cable :).
I have not really had the time to play with it,but needs must, so unless these things are a quick fix then it will have to go. It does not owe me much so no great loss.
Yep need to organise a meeting and chew the fat.
Be in touch.
 

·
Registered
Joined
·
13,685 Posts
GT is dieselly but good :D. Cable is actually better if less convenient. Will sort something soon Phil.
Take Care.
 
1 - 8 of 8 Posts
Top