Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
748 Posts
Discussion Starter #1
156 Sportwagon. 2004. 1.9 16v JTD M-Jet.

I seem to ( and have been told ) that I am getting low MPG on my bella.

I have monitored my consumption by going brim to brim...so my MPG calculations are pretty
accurate.

This is town driving only ( In London ) - short trips - so not getting up to temperature that often.

I'm getting 33 MPG in these conditions - and have been told by an Alfa garage that that is low. :cry::cry::cry:

So what should be investigated?

It's had a service recently - so fresh oil and air filter.

I'm thinking to clean the EGR unit this weekend. Anything else to look at?

I'm going on a long trip to Germany over the Xmas season...so this will give me a chance to gauge the MPG over a decent trip.

cheers all

:):)
 

·
Registered
Joined
·
748 Posts
Discussion Starter #8
I love that onboard comp...such sweet lies....:lol::cheese: . Can't we take out a class action for emotional damage? :D
 

·
Registered
Joined
·
28,482 Posts
Hello Daytona........:)

I've got the same engine as you ( I think ) on a late 2006, 147 Ti, and I average about 33 / 35 around town, and have done since I bought the Car new. However on long drives, with the cruise control on, in 6th gear, and at a steady 75 mph, I usually get around 55 sometimes 60 MPG, if its really flat, so I don't think there is anything wrong with your Engine at all, and as somebody else has said......." Keep Driving "........:thumbs:
 

·
Registered
Joined
·
18 Posts
I have to agree with N13roy... I get about the same performance and have the same engine.... my biggest problem is a heavy right foot.....
As the performance increases through good maintenance my foot is getting heavier...lol
Try changing all the filters and see if that helps....
 

·
Registered
Joined
·
748 Posts
Discussion Starter #11
Going on a trip to Germany tomorrow - so will see what a good run produces in terms of MPG figures. :)
 
1 - 13 of 13 Posts
Top