Alfa Romeo Forum banner
1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
Seems to me the South African 155's were not fitted with the self healing options!(nor the mounts for a rollcage?)
The passengers side carpets on my Super is drenched in a funny smelling, feeling fluid. At first thought it could be the carwash attendantds that spilled some of their silicon liquid and tried to cover it with the loose rubber mats, but I dried it a week ago and today they were wet again and no carwash!
I can not see any fluids needing regular topups although the checkpanel ( little radiator with fan) seems to light up regularly - although the coolant levels in the container stays put!
Anyone with same exp.. and a remedy?
thanks
Sieg
ps. It hasn't rained here for quite a while so its not a leaky door rubber or windscreen. :(
 

·
Registered
Joined
·
1,183 Posts
sounds like the heater matrix tap? thingy majigan leaking nice antifreeze into the footwell, there was posts about this ages ago i think its not that hard to correct but if you have an amp fitted with the wire through the bulkhead check the scuttle panel drainhole is not blocked as if u have used the factory gromet to feed an amp wire through and have not siliconed it the water from outside quickly comes inside and runs down the ecu!!!!!!!!!!! this happened on my rhd car. :eek:
 

·
Registered
Joined
·
1,808 Posts
speed freak said:
Go for the heater tap..............only about £10 to buy and a doddle to fit ;) :D takes about 15 mins :D :D
thats after you've spent most of the day removing the lower half of the dash etc...... :D

san
 

·
Registered
Joined
·
4,651 Posts
sanitary said:
thats after you've spent most of the day removing the lower half of the dash etc...... :D

san

Why????????????? :confused: :confused: :confused: :confused:

You need to take two trim`s off and there held on with a total of 6 screws takes a couple of mins ..............and the Tap`s there :rolleyes: a pipe a cable and 2 bolts and off it comes................could`nt be easier
 

·
Registered
Joined
·
1,808 Posts
speed freak said:
Why????????????? :confused: :confused: :confused: :confused:

You need to take two trim`s off and there held on with a total of 6 screws takes a couple of mins ..............and the Tap`s there :rolleyes: a pipe a cable and 2 bolts and off it comes................could`nt be easier
Then I must have done it wrong then :confused:

san
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top