Alfa Romeo Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
when i reach 2500-3500 rpm. in my 2.0 ts 16v.
it start to make some rattle or something..
It sound like a lose heat shield, but they ain't loose. it drives me crazy..aarg
:mad:
 
G

·
Discussion Starter · #2 ·
Hi,

A similar noise on mine was due to some baffles inside the silencer being loose. It was especially noticable on lift-off from high revs as the gas pressure dropped.

A good excuse for a nice custom stainless one? :)

Alex
 
G

·
Discussion Starter · #3 ·
Could be the dreaded catalyst?

Mine went once, and it too drove me crazy for ages! If i was you i'd get that checked,
mine was completely shot, and the insides had broken up completely causing the rattle.

Regards,

A.h
 

·
Registered
Joined
·
715 Posts
I had this on my 1997 155. There is a little heat sheild spot welded in 4 places to the downpipe just before the cat. Two of these welds broke and I tied the rest on with stainless steel wire. Then the other two welds broke and I took the whole lot off and have had no side effects.

The other thing it could be is the plastic under tray for the engine if your car has one. This often drops down and catches on things.
 
G

·
Discussion Starter · #5 ·
I had the same thing as henry, except i ripped it off straight away... no side affect seen.

J
 
G

·
Discussion Starter · #6 ·
I also have that noise. My exhaust is brand new, removed cat, don't have that thing on the down pipes, and also not plastic undertray.
What about that small box just after the lambda sensor? Couldn't that be it. Although tapping mine with the hand doesn't make any noises. Maybe I am not hitting hard enough....Anybody know what that is by the way? If it is a pre-cat, is it also restrictive, or not?

Good luck
Jacques
 
1 - 6 of 6 Posts
Top