Alfa Romeo Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 · (Edited)
As I promised, I would like to share my experience with issue that keeps my alfa in the service.

I was driving the highway in the, let's say, very heavy rain, wall of water, special lightning effects included. As on the highway, my traveling speed was high, close to 90-100 MPH. Then something odd happened. I got rear plate light system error, shortly after followed by front lights system error (the light remained operational). Few miles later, still in rain conditions, Start/Stop system failure appeared and almost immediately parking sensors also went off. Both those systems can be turned on and off by pressing button with the little light on it that indicates if system is on or off. Lights on the buttons were randomly blinking without any interaction from me. Then also the collision warning system went off. Highway was in the middle of nowhere, rain was still falling and I have Parking or Gas station to stop. Shortly after that, check engine light appeared, car went into safe mode with DNA disabled, and I still got around 50 miles to drive before I could put my car in a dry garage. In those circumstances, without any safe opportunity to stop the car, I decided to continue driving as I was worried if the car will even start again after turning the engine off. Finally I made it, I got home, I left Giulia to dry in a warm garage.

The next day I checked the car. After restarting the engine a few times most of the errors disappeared, only start/stop system stayed offline. I went to dealers, I left the car for service. After connecting Giulia to the computer interface they found active errors caused by front lamp and parking sensors. According to procedure They contacted Italy and waited for further instructions. Week later they came to the conclusion that one of the lamps may be faulty, but to be sure they have to take off the front bumper replace the faulty lamp with my other working one and check if it is the case. After getting this exchange done, service concluded that the lamp indeed is faulty, but also alternator needs to be replaced. So right now I am waiting for parts shipping from Italy, full of worries if they fit my front bumper properly after the works.
 

·
AO Detailing Car Of The Year 2020 Winner
Joined
·
4,146 Posts
Thanks for keeping us posted on issues. That doesn't sound good zb00j! It looks to be water ingress related problems from your description of how the errors occurred. Are your workshop asking Italy AR for a proper solution to fix the problem permanently if indeed it is water ingress shorting out electrical components or lights? Just replacing the lamp unit is not going to fix the issue long term as it could happen again in heavy rain. I am more concerned as to why the alternator needs to be replaced!!! As you may know, Omi's Qf needed ECU replacement due to water ingress and it turned out to be a faulty scuttle panel. Can you find out more details regarding alternator and the long term fix? It may be worth registering a case with customer car so that the problem is given the right level of importance. Its not uncommon on new cars to have teething troubles, but it important they are fixed and future proofed as and when issues are identified. AR do seem to be taking these issues seriously from my experience.

I wouldn't be too worried about the bumper. Mine was removed to change a parking sensor and it was all fitted back fine. Its no different to any other car.
 

·
Registered
Joined
·
7,861 Posts
I believe reading that thread omi's problem was a LHD scuttle panel fitted to his RHD model?

Either way it's becoming increasingly evident the Giulia doesn't like the rain! Probably doesn't like automated car washes either........
 

·
AO Detailing Car Of The Year 2020 Winner
Joined
·
4,146 Posts
I have washed it plenty of time using a Pressure washer. But I let it stand overnight before driving usually. I do open the hood and clean the engine bay soon after a wash on most instances and I havent really noticed any water in places where is should not be. Heavy rain at 90mph is a different story though as there is spray from multiple directions! Will need more information before we can decide its a latent issue waiting to happen.
 
1 - 4 of 4 Posts
Top