Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
447 Posts
Discussion Starter #1
Hi all,

Got an issue with my windscreen washer bottle ejecting fluid into the engine bay which is making a bit of a mess as I'm trying to keep the bay clean.. I posted over at Stelvioforum.com and haven't had any replies to say anyone has experienced the same issue. However, I reckon most of the users over there have left hand drive models (whether that makes a difference?). I refilled the washer bottle with about 3 pints of fluid to see how full the bottle was so it was still spilling some - the 3 pints.

Cheers
 

Attachments

·
Premium Member
Joined
·
7,531 Posts
Looking at the reservoir, I can't really see how this could happen, unless it's a problem with the washerpump generating backpressure or something.....
see
wipers stelvio.pdf

I think you can get access removing the wheelwell liner
 

·
Registered
Joined
·
447 Posts
Discussion Starter #3
jwq, thanks for the document, great to see some diagrams for these motors.. I ran out this morning and put a white micro cloth around the neck of the filler.. stopped after a few minutes and it was wet with fluid? Am not even using the washers or wipers at this point unless they pressurise in the background.. I'll try and get a photo of the neck of the washer bottle at a different angle.. looks like when you add fluid it doesn't go straight down like normal bottles with a long neck, on this it goes straight into a right angle piece and doesn't look to allow gravity to keep it in the tank? however if it's just me i'm obviously talking rubbish or have a weird setup on the particular car.. cheers
 

·
Registered
Joined
·
447 Posts
Discussion Starter #6
Just cut out a piece of sponge to fit in the filter cup inside washer cap but all that did was collect more fluid which subsequently come out the cap... although a fail it shows the fluid is coming back up the tubing to the filler hole. Looking at the diagram (the light blue image with all the numbers) it appears that if the bottle is full then fluid will easily make it's way to the filler as the available space in the tank is almost level with the filler?

Why it's leaking on mine and nobody else is weird. Maybe most tanks are empty.. or there's some sort of non return valve in the tubing missing..

cheers
 

·
Premium Member
Joined
·
7,531 Posts
..... Looking at the diagram (the light blue image with all the numbers) it appears that if the bottle is full then fluid will easily make it's way to the filler as the available space in the tank is almost level with the filler?

Why it's leaking on mine and nobody else is weird. Maybe most tanks are empty.. or there's some sort of non return valve in the tubing missing..

cheers
yeah, light blue is same as dark blue, just front and backside view....
I also thought about non return valve, but can't find any mention of this..... It's a weird problem.
 
1 - 7 of 7 Posts
Top