Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter #1
I've been noticing a strange noise - on what sounds like the belt side - coming from my engine when warm. The best I can describe it is a chugging steam engine kind of sound when idling, almost like a quieter Chitty Chitty Bang Bang idle.

It's not that loud but it's an odd sound nonetheless. It definitely sounds like an air produced noise and I'm sure it's most prominent after a good, hard drive. The oil/water levels/temps are all OK.

Any ideas?
 

·
Registered
Joined
·
449 Posts
Discussion Starter #7 (Edited)
was your air con on?
Nope.
electric fan ?
Nope.

Can't believe you guys don't know Fred Dibnah and what he achieved in his life. :wow:

Anyway, I'll try to elaborate on the noise. It's part of the idle speed. Imagine the noise a steam engine makes - the chug of a steam train but obviously not as loud! :lol: Almost an escaping air chug.

EDIT: Listen to this, just the chugging steam noise. Imagine that with the usual V6 idle and you've got it. http://www.youtube.com/watch?v=rXbOqeniCDE Does that help? :D

I've just thought, considering it's only really noticeable when hot, maybe it's a knackered gasket or water pump? Steam pressure?
 

·
Registered
Joined
·
178 Posts
are you sure its not a rubbing noise? like a belt tuching a cover or something? or a bearing on one of the pullys?

Sean
 

·
Registered
Joined
·
38,889 Posts
I have had a spark plug eject itself from a TS head due to the thread failing.

It started off with a ticking, then became a chugging, then it sounded like a tractor and ran on 3 cylinders.

It also destroyed the coil on its way out.


I think one of the plugs is loose but If the thread is stripped I know where to get a kit to fix it with the head in situ.
 

·
Registered
Joined
·
471 Posts
I've been noticing a strange noise - on what sounds like the belt side - coming from my engine when warm. The best I can describe it is a chugging steam engine kind of sound when idling, almost like a quieter Chitty Chitty Bang Bang idle.

Any ideas?
ooh they all do that Sir......
 

·
Registered
Joined
·
449 Posts
Discussion Starter #13
I think one of the plugs is loose but If the thread is stripped I know where to get a kit to fix it with the head in situ.
Good thinking mate, didn't even enter my mind! And yes, that's exactly the kind of noise a loose plug would make. I'll have a look when I've got time and update this. :thumbs:
 

·
Registered
Joined
·
182 Posts
Good thinking mate, didn't even enter my mind! And yes, that's exactly the kind of noise a loose plug would make. I'll have a look when I've got time and update this. :thumbs:
Worth checking, but wouldn't the noise be more pronounced with the engine cold if it was a loose plug and you'd possibly notice a performance drop?
 

·
Registered
Joined
·
38,889 Posts
Worth checking, but wouldn't the noise be more pronounced with the engine cold if it was a loose plug and you'd possibly notice a performance drop?
I didn't notice much performance difference on mine until the plug came out completely.

The noise whilst it was loose was about the same whether hot or cold.
 

·
Registered
Joined
·
182 Posts
I didn't notice much performance difference on mine until the plug came out completely.

The noise whilst it was loose was about the same whether hot or cold.
Fair enough, it's just that the OP mentions the noise is there when the engine is warmed up...hence my question.

Only other thing that could make that sort of noise is manifold being cracked, although again it's more likely to be noisy when colder.

Regs
Jules.
 
1 - 17 of 17 Posts
Top