Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I collected my brand new Mito in December 2009, from day one my brakes have been grinding but I assumed they just needed bedding in so i gave it a few months. I rang the garage in February to advice them of this problem. I had the car seen in April for this problem and others and was told that for the garage to even look at the brakes to see if there was a problem would cost me £90 as it was classed as wear and tear!!!!
I advised them that this had been happening since I have had the car but they said that even if I had bought the car back the next day it would still be wear and tear!

I am now worried that if anything major happens that I will get the same response 'wear and tear'! It doesnt fill me with much confidence in the warranty!
 

·
Registered
Joined
·
41,769 Posts
other people have had their brakes done under warranty as its a known fault on the mito...get in touch with aruk and get them to sort it for you, use the freephone number you have for the AA and use option 3....:)
 
B

·
Guest
Joined
·
0 Posts
Try another dealer, no saying it has to go back to where it came from for work...

Sent from my HTC Legend using Tapatalk
 

·
Registered
Joined
·
473 Posts
I thought someone actually posted the reference code for the brake issue before...? So it is a known issue to be fixed under warranty...
 

·
Registered
Joined
·
1,341 Posts
The number posted was specific to the MiTo 155TB which has different brakes to the other no MA MiTo's so not sure if there is a known issue with the others. A call to ARUK customer line should be able to answer it for you
 

·
Registered
Joined
·
473 Posts
If it's any consolation every Subaru I have ever had had squealing brakes from new, and for that matter every Peugeot... I just copperslipped the backs of the pads myself.. twenty minute job. You say it's binding though....
 
1 - 10 of 10 Posts
Top