Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
5,682 Posts
Discussion Starter #1 (Edited)
Hello

Touch wood,i haven't needed your help for a wee bit but i do now.

Started car today.noticed that when i turned the steering wheel,there was a wee bit of knocking....then i noticed the above mentioned warning lights.

I've had the VDC on before on it's own but that seemed to fix itself a good few months back...now the 2 are on...and it's the MCSF one that concerns me the most.

I'm gonna get it on diagnostics tomorrow...but could anyone shed any light on the matter and how serious,mechanically or financially are we talking ?

The car drives ok,but i've noticed that she's not as smooth,with periodic jerkiness.

Any ideas ??

Thanks

Ronan

Right,i've just noticed this...could i be barking up the wrong tree ?

http://www.alfaowner.com/Forum/alfa-147-156-and-gt/149574-steering-wheel-removal-now-vcd-failure.html
 
L

·
Guest
Joined
·
0 Posts
its an open question with many many answers, until you get the car diagnosied & post the error codes we'd be only giving wrong advise, but at a guess i'd sayt he steering sensor is gone defective. i assume your car has a Face-Lift interior as you are talking about VDC.
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #3
Thanks Lacken

Yeh,it is a facelift interior....if it is only the steering sensor that's gone...does that mean that the VDC has actually disabled ?

The MCSF is the only thing worrying me as it's my wife who drives the 156 most.


Why would that warning light come on also ??
 
L

·
Guest
Joined
·
0 Posts
the list of reasons are too long to post here, get the codes read & report back to us.
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #6
Okay...diagnostic results :

1. P0100 MAF
2. P0022 Variable Camshaft Timing

3. P0500 Vehicle Speed Sensor
4. C1505 Dynamic Stability Control Left Rear Valve Malfunction

I'm guessing that numbers 1 and 2 have nothing to do with the MCSF & VDC warning lights coming on.
Perhaps i'm wrong ?? Are these just a nasty "brucie bonus" ?

And in turn then numbers 3 and 4 are linked together to these warning lights

First question...how serious,safety wise are the above faults...and how much are we talking about money wise?.....i'm useless with the spanners !! :rolleyes:
 
L

·
Guest
Joined
·
0 Posts
C1505 is your issue. sound like any issue within the ABS/VDC module. Try disconencting the battery for an hour & take it form there
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #8
Battery disconnected for about 90 mins...restarted...still same warning lights :(

Took her out for a short drive...noticed when i accelerated she drove fine,but when i took my foot off the pedal,she jerked a bit......MAF related ?? I did take the MAF connector off half way through trip but got the same jerking.

Also when i braked hard but not too hard,i got a juddering noise from the brakes...lack of ABS ???

Money's a bit tight at the moment...but i'd like to get the 156 fixed...she seems a bit off colour at the moment.

Should i just let my local mechanic have a go at the C1505 fault..or does it have to be an Alfa indy?
He's done good previous work on her at decent prices but he says it could be about £150 to fix the C1505 fault.
Would this be about right ??
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #9
As i said,money's been a bit tight,but she's going in next week to an Alfa Indy to get the cambelt done,so the VDC light will be looked at too....keep you updated.
 

·
Registered
Joined
·
1,134 Posts
Hope its a cheap fix m8 :)
I think alot of people are in the same boat cash wise.... I am having my cluch/rollbar top/bottom arms done at the moment.

P.s anyone want to buy a kidney? :p
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #11
To be honest,i'm one of those that love Alfa...and have to take a lot of hassle for doing so from non Alfa drivers,even though i don't have a lot of cash...but after the last one's cambelt failure.....this one's going in...she's 9 years old,only done 57k,but i'm not risking it.

Hopefully the VDC warning light is not gonna be too dear...gotta Indy in Belfast who knows his stuff.....wish me luck !!!!
 

·
Registered
Joined
·
1,134 Posts
Good luck, is it possible that 1 and 2 are old errors? if its been fixed but not cleared then it maybe just still on there, on mine I wiped the errors and they stayed gone :)
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #13
Good luck, is it possible that 1 and 2 are old errors? if its been fixed but not cleared then it maybe just still on there, on mine I wiped the errors and they stayed gone :)

Possibly....don't think they've anything to do with problem...but then i just got local garage to put them on diagnostics....let's see
 

·
Registered
Joined
·
9,912 Posts
Possibly....don't think they've anything to do with problem...but then i just got local garage to put them on diagnostics....let's see
you disconnected maf ..remember to tell garage that so they can delete codes then they can re read them
 

·
Registered
Joined
·
9,912 Posts
if you disconnected maf and had engine running ..ecu will show a fault code or 2 ie p0100 and p0110 if i remember right ..garage will assume you got maf problem when you may not have .ps any wires sensors you have unplugged you must tell them or you can send garage on wild goose chase at your expense
 

·
Registered
Joined
·
5,682 Posts
Discussion Starter #17
if you disconnected maf and had engine running ..ecu will show a fault code or 2 ie p0100 and p0110 if i remember right ..garage will assume you got maf problem when you may not have .ps any wires sensors you have unplugged you must tell them or you can send garage on wild goose chase at your expense
...when diagnostics were done originally MAF was still plugged.

Indy will probably re diagnose anyway. :thumbs:
 
1 - 18 of 18 Posts
Top