Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1
Last two days I have had an Amber triangle with an arrowed circle around it warning light on my dash that flashes on for a second then disappears, it happens once or twice on a 15 mile journey. It is next to the ABS warning light. Only thing I have done recently was change the battery on Friday and wash the car with a jet washer on Saturday, its not done it before this weekend.

Is it my traction control ?. Is it dangerous?. Anything I can fiddle with to eliminate it? Could it be low brake fluid? Any ideas people?
 

·
Registered
Joined
·
4,196 Posts
When did the light appear?

If it appeared while you were putting power down, especially around a corner or on a wet or gravelly surface, it just means the traction control is working.

If it just appears while cruising, it may be a problem.
 

·
Registered
Joined
·
270 Posts
Discussion Starter #3
When I started the car and moved off, then when braking gently and once when cruising. Literally just beeped on then disappeared again.
 

·
Registered
Joined
·
3 Posts
Traction control and ABS

Hi, I have exactly the same problem. Every now and again the traction control and ABS light will flash for a fraction of a second in situations where you wouldn't expect it to. Ie in a straight line just normal driving and no slipping. was in the garage and they couldn't see any ABS faults on the diagnostics. has anyone any ideas
 

·
Registered
Joined
·
701 Posts
Hi, I have exactly the same problem. Every now and again the traction control and ABS light will flash for a fraction of a second in situations where you wouldn't expect it to. Ie in a straight line just normal driving and no slipping. was in the garage and they couldn't see any ABS faults on the diagnostics. has anyone any ideas
Do you have same size of tires all around? Could be the cause if not.
 

·
Premium Member
Joined
·
1,850 Posts
Do you have same size of tires all around? Could be the cause if not.
Even the same size, but a new one vs a part worn across the same axle.

ps, mine flashes at least half a dozen times a day, now that the weather is changing, but I think that's due to my lead boot. :shocked::driving:
 

·
Registered
Joined
·
2,625 Posts
Could be a misreading of the speed. Does the speedo stay steady when it happens?
Also I note you power washed the car so I'm wondering if the moisture affected the individual wheel speed sensors.
 
1 - 9 of 9 Posts
Top