Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1 (Edited)
I am experiencing vibrations when accelerating harder then usual on 3/4th gear.
Another problem is random grinding/knocking noise probably coming from driver's side. I have recorded the video of this noise. Please watch with speakers full on.

https://www.youtube.com/watch?v=jU5dm-6ohEI - most obvious noise at 0.50 minute

Could this be suspension problem?
m32 Gearbox problem?
Driveshaft maybe?

Anybody experiencing same problem?

Thanks!
 

·
Registered
Joined
·
387 Posts
knocking probably is suspension related you will need to jack the car up but as for vibration your driveshaft is knackered ,i had the same on 3/4 and it got worst finally making car hell to drive
 

·
Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
6,563 Posts
Drive shaft joint.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
knocking probably is suspension related you will need to jack the car up but as for vibration your driveshaft is knackered ,i had the same on 3/4 and it got worst finally making car hell to drive
Thanks for the info! Have you replaced the driveshaft?

My mechanic recommended to remove the driveshaft and re-lubricate it. You think that this will help or is it just a waste?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Knocking & Squeaking noise was sorted - ball joint in upper wishbone from driver's side was gone. sorted by replacing the wishbone:

55 pounds labour
135 pounds wishbone

Although the car still vibrates while accelerating on 3-4th gear.
Mechanic checked the driver-shaft and said that it look aright
or does it?
 

·
Registered
Joined
·
11 Posts
Hello. I have the same problem with the vibration under acceleration (1.9 JTDm 150hp) Just when accelerating from under 2000 and only for a short time. From 1800-2100 rpm. 3,4,5 and 6th gear. If i accelerate from above 2000 it will not vibrate. I replaced clutch, flywheel, CV joints left and right. And today i change the whole right drive shaft. Two weeks ago i changed the driving belt and accessories. I also removed the swirl flaps, DPF and EGR is off. I also changed the engine mount from the gearbox. I still got the vibrations!!!
It's driving me crazy and i really don't know what is there left to change. Someone said it could be the gearbox. :(
 
1 - 7 of 7 Posts
Top