Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi there
My 156 2.5 V6 had some vibration problems when driving over 80km/h
Wheel balance guy told me it's probably the bushing.
Checked under car, and all bushing looked ok but the left hand front driveshaft had a bad movement inside the the diff.
Took the shaft out and managed to pull the inner half shaft out.
It looks ok but when I tried to refit, it still has some movement and looks like there is still a gap between the shaft and the diff box - when pushing in- it's making a 'nice' click sound...
Any ideas?

Some photos and video in link below to show movement of driveshaft-

Alfa 156 V6 25 Photos by topaz489 | Photobucket
 

·
Premium Member
Joined
·
19,119 Posts
You've had the wheels balanced yes?If so I'd suspect the shaft. Not the diff
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks Joss
I have taken the shaft out and it looks/feel steardy.
I had the boot split earlier in the year but replaced it before the CV started clicking...
As I mentioned in the last post... the shaft looks like it's not sitting firmly inside the diff...did you have a chance to look at the video? is this movement normal?
How do I check if the shaft is buggered?
Cheers
 

·
Registered
Joined
·
831 Posts
The diff bearings are shot, split the box and fit new ones(as per service manual)or get another box. Was it sudden or was there play last time it was serviced? Don't drive it!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Hi MULTIVITZ.
There is no unusual noise when driving...
Just vibration over 80km/h.
As said noticed the 'play' between shaft & diff - would there be any unusual noise from the diff bearing is they are shot?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Also, MULTIVITZ, I forgot to mentioned... as per your question...
The vibration started after front wheels change.
The wheels had some tread wear and needed replacement/ alignment - the tyres guy said I need new bushing but I couldnt find any movement in bushing, just the play in shaft...
Does this help? I'm still lost!
Cheers
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Hi all.
It could be any of the problems above...
I posted a link for a video showing the 'play' in the shaft flange to diff.
Did any of you had a chance to look at it and can tell me if its normal?
Cheers
 

·
Registered
Joined
·
831 Posts
After wheel change, with balancing, deformed tyre casing from factor or storage causing problem? Borrow some wheels from someone who has no problems and go for a drive and see, would be my next move.
 
1 - 9 of 9 Posts
Top