Alfa Romeo Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
741 Posts
Discussion Starter #1 (Edited)
I bought a 2.4 with snapped belt which as you can see in the video is running but it's very Smokey, I've had it running for 20 minutes and it's still as bad and I'm wondering if you could shed some light.
I know the 2.4 sufferes with heads but I've no over heating or oil in the coolant bottle, it's actually pretty clean.
I've had to remove the injectors a couple of times as the seals weren't doing their job and leaking diesel and the base of them if very black not like clean diesel on them ..

What you you reckon ?
 

·
Registered
Joined
·
741 Posts
Discussion Starter #4
Does it smell like oil?.. Could be your turbo leaking oil into intake.
Oh that's a point .
Now that you.mention it , it does smell slightly oily.
I'll have a look in the inter cooler pipe and seeing its dripping with oil, thank you for that.
 

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
5,799 Posts
The smoke would be the least or my concerns....it sounds horrendous!....never heard a 2.4 sounding quite that "tractory".
 

·
Registered
Joined
·
3,314 Posts
I shouldn't worry too much about the noise, phone cameras pick up and amplify noises quite well.

That idle seems a bit high though, assume that's running cold?

Can you take it for a good run out, see if that clears it up (assuming it's taxed and MOT'd)
 

·
Registered
Joined
·
741 Posts
Discussion Starter #7
The video was after 5 minutes Of running from cold, the seal on 2 injectors are still leaking and theres a puddle of diesel on the floor when the cars reversed back into the garage so that might be the tapperty noise ,
I cant take it for a spin as theres no power steering or alternator belt fitted, 'm waiting for it to arrive.
 

·
Registered
Joined
·
741 Posts
Discussion Starter #8
I've just thought which I forgot to mention was I couldn't find the 4 pins from the 2 broken rockers .... they couldn't of got wedged in a spring could they and be the cause?
Ive removed the map sensor to see how bad it is and its relatively clean and more Importantly, dry, not wet with an oily wet deposit ....
 

·
Registered
Joined
·
3,775 Posts
You say 2 injector seals are leaking,take it you mean the copper washers that seal injector to the head? Is so get them sorted and see how it is then as loss of compression could be causing poor combustion.

assume you have repaired it after broken belt so tappet noise could well go after being run for a while and lifters have filled up properly post repairs.
 

·
Registered
Joined
·
741 Posts
Discussion Starter #10
Yes the copper washers , the usual placebo get them is still shut after a year and living in a small town I thought I'd go to Shrewsbury yesterday but non of the Car parts places stock them so I've had to make do with the old washers.
The 2 leaking.injectors are puffing out smoke as well as fuel so it's not running right.

The cars been rremapped has a stupid K & N air filter and a dump valve fitted, it's been a Yoofs car so I'd imagine had some hammer
 

·
Registered
Joined
·
741 Posts
Discussion Starter #12
Ill have to buy those as I've been everywhere today and no one has my size , they have thinner to double up but I'd rather keep them the same.
I removed the injector to get the seal out at the base of it is covered in an oily diesel mix which explains the smoke, I've not took the intetcooler pipe off yet to see how bad it is but I've.removed the.map a couple of days ago and that was bone dry and clean
 

Attachments

·
Registered
Joined
·
3,775 Posts
Looks like mixture of fuel and carbon to me rather than oil. Looking at that injector I would say the beemer ones will fit. Fairly sure it’s just the thickness that varies between different manufacturers the other dimensions are the same for Bosch injectors.
 

·
Registered
Joined
·
741 Posts
Discussion Starter #14
I've ordered them so thank you for that, now regarding the carbon, remove the manifold and clean it ... ?
 

·
Registered
Joined
·
3,775 Posts
I wouldn’t as it’s normal to have carbon in the combustion chamber,with a leak like you have it will be worse.
I would sort the injector leaks and then give it a good run and see if smoke out the back clears.
if you had a big build up of gunk in the manifold the map would have been dirty.
 

·
Registered
Joined
·
137 Posts
Do not run that engine any more without replacing the turbo internals with a kit from Mellet Turbos in the UK. If there is even the lightest chance that the turbo seal is bad the engine will take off and run out of control on the sump oil. If it does your engine will be destroyed beyond economical repair. That happened to our 2.4 Sportwagon. It was an absolute nightmare. It is not worth taking a chance on yours being ok. Oily smoke is a very scary scenario in my experience. I would not run one of those engines, or any turbo diesel, over 170,000km without replacing the turbo internals because it is cheap insurance.
 

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
5,799 Posts
No need for scaremongering....what happened to yours was a very unfortunate and rare accident....only ever seen one engine destroyed like that in all my years in the trade. Usually the turbos smoke loads before that happens (although the one I saw was seriously over filled with oil...no turbo issues)...or sometimes a terminal turbo failure with no warning....which can happen at any miles. Mine has 160,000 miles (258,000km) on the original turbo....I'm not replacing it for something that is extremely unlikely to happen. Probably 99 plus percent of turbo failures do not result in any sort of engine damage or a runaway. Also most rebuilt turbos and rebuild kits are far inferior to the original in quality. In the OP case we have no idea if its the turbo causing the smoking or not....more investigation required before he throws money at a new one. Turbo seal failure rarely shows at idle but an easy and fairly good way of checking them is to let them idle for a few minutes then momentarily push the throttle to the floor....a big ball of blue smoke points to the turbo main seals (or even valve stem seal)...no smoke or black smoke... look elsewhere.
 

·
Registered
Joined
·
741 Posts
Discussion Starter #18 (Edited)
The belt has arrived today so I'll attack it tomorrow, I'll have to change the alternator as that doesn't seem to be charging the battery but I've removed the bottom intercool pipe and the plastic pipe coming off the throttle body and the pipe is relatively free of oil, it's not swimming in it and I'd say I've.more in my 170,000 1.9 so I reckon the turbo is ok ...

Back tomorrow

P.s ....
The car is to be stripped as the Yoof , it seems, wasnt very good at judging distances and is scared everywhere, plus the rear sill has a hole in.
I'd like the engine to run perfectly so I can either sell it as a whole , transplant it or sell just the head.
 

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
5,799 Posts
Most of that oil will probably come from the PCV....
 

·
Registered
Joined
·
9 Posts
Hi if you're stripping it I need a couple of bits, where abouts are you located and whats the paint code pls

Sent from my SM-G975F using Tapatalk
 
1 - 20 of 22 Posts
Top