Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
780 Posts
Discussion Starter #1
Hey guys,

It would seem I've got a slightly noisy/rattling variator when the car is cold. Like most early onsets the sounds usually disappears after only a few seconds and if the engine is at temperature and I start it up (say I quickly nipped into the shops) then there is no noise at all.

My research seems to indicate that its best just to leave it until the belts get done as I am planning on getting them done within the next 6 - 12 months. But just want to re-confirm that this would be the best course of action?

Cheers,
- Alex
 

·
Registered
Joined
·
190 Posts
Hi Alex, Mines the same... Sounds like a diesel on a cold start but disappears after a few painful seconds.

A local indie Alfa mechanic (he's Italian to boot) told me not to worry as there's usually years of life left if the noise goes away quickly.

It will need replacing but best, as you noted, to leave it till the bigger job of the belts and water pump.

Steve
 

·
Registered
Joined
·
780 Posts
Discussion Starter #3
Hi Alex, Mines the same... Sounds like a diesel on a cold start but disappears after a few painful seconds.

A local indie Alfa mechanic (he's Italian to boot) told me not to worry as there's usually years of life left if the noise goes away quickly.

It will need replacing but best, as you noted, to leave it till the bigger job of the belts and water pump.

Steve
Just as I thought, cheers mate!

Means I can focus on those new brakes I've been eying off since buying the car :D
 

·
Registered
Joined
·
780 Posts
Discussion Starter #5
Was hoping to get some DBA's but looking at some of the prices I am seeing (eg. $165 each for a slotted rear) I think it might just be best to import some Brembo GT Sport's from Alfisti. Would cost me less (~$200 excl. shipping for both rears) and could use the extra cash to get some EBC greenstuff all round. Plus their shipping rates are exceptional.

Especially compared to Gazzella Racing who charge an arm and a leg for shipping :(

EDIT: Found some well priced RDA's but reckon they are only for 97-99 TS. Reckon they would be compatible with an '02 TS?
 
1 - 5 of 5 Posts
Top