Alfa Romeo Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi guys I have had the light on fo a while now and my last car was a golf so I have a vag cable but for ease I bought an OBD2 reader but I just keep getting the linking error.

So I decided I would try and mod the vagcom cable but after searching on here I cant find out how to do it can anyone help or point out a link where it tells you how to do it.

Thanks in advance
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
cheers guys its the airbag light thats lit.

Gonna check the connector tomorrow under the passenger

Mines 1999 2.0TS so am i right that theres no side bags on these.
 

·
Registered
Joined
·
30,067 Posts
Ahh the mod for that is changing the pinouts. Pin 7 move to pin 3 IIRC, but you can fit a small 2 way switch and have it connected to both and switch between the pins depending on what you want to connect to.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
Looks like im stuffed with this cable as its all circuit board.

Does anyone have any ideas why my obd2 reader doesnt work on the alfa.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
well the one I tried originally with fiatecuscan was a Vagcom.

The the OBD2 I have is a maxicon 3200 or something like that.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #14
This might be a stupid question but if I disconnect the battery clean up the connector under the passenger seat and leave the battery off for a few hours would this reset the light when the ecu does ots start check or is that just wishful thinking it used to work on the golf with the ABS warnings.
 

·
Registered
Joined
·
30,067 Posts
I've got that one too, although never used this one on an alfa as it was from my old VW days. TBH it wasn't that good at connecting to my Passat either :lol:

The KKL I modified was like the one in the link I posted previously, it was for my mate when he had a 156 V6.

I've had to modify a ELM327 also, but that was much more detailed then the KKL mod.
 

·
Registered
Joined
·
30,067 Posts
This might be a stupid question but if I disconnect the battery clean up the connector under the passenger seat and leave the battery off for a few hours would this reset the light when the ecu does ots start check or is that just wishful thinking it used to work on the golf with the ABS warnings.
Don't think so. Can try though.
 
1 - 20 of 26 Posts
Top