Alfa Romeo Forum banner

1 - 20 of 48 Posts

·
Registered
Joined
·
10,915 Posts
Discussion Starter #1
New Battery worked a treat.
Poor running 2.5 for about a year Still run so still used it
Great running 3.0 since i got it last May.

Would have swapped mafs over before now BUT as 3.0 2001 it was listed as a different maf on ********* web site.

Check on eper with chassis no revealed its the same MAF.

So today swapped the maf sensors over.

Great running 2.5
Pathetic running 3.0.

So swapping back and as the 3.0 suffers a couple of misses when cold I am going to replace both mafs..

Saw a good one for £89 on ebay from an Alfa dealer but on enquiring it was NOT the V6 one ....It never is.It was in the region of £180.

Has anyone used the following maf.

http://cgi.ebay.co.uk/ALFA-ROMEO-46444287-Air-flow-sensor-meter-156-V6-NEW_W0QQitemZ250079710692QQihZ015QQcategoryZ10370QQrdZ1QQcmdZViewItem

I know portland dont get a great write up but they cant be making up all that positive feedback.


Can anyone help answer,

1) What is the normal working life span of a MAf (2.5 or 3.0 V6)
2)Has anyone had a good result from a Portland MAf.
3)Can anyone advise a good source to get 2 V6 mafs,

Thanks
Pomeo.
 

·
Registered
Joined
·
6,300 Posts
don't bother with Portland....give steve at Alternative Autos a call and he'll sort you out with a genuine one for about 90 quid delivered....
 

·
Registered
Joined
·
6,300 Posts
bloody hell - portland have got a nerve selling their useless chinese ones for the same price as genuine ones....avoid unless you like taking your maf off over and over again.....
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #4
Thanks Niall for your replies.Looking for thank post But cant find it.THANKS anyway.Must be italian software on this site.

Also read with interest the posts about the bulb failure cicuitry...The problem is the problem finding circuitry causing the problems.Its getting so complicated like the chicken and the egg.

Also WHY knowing the MAf failure problems NOTHING DETECTS it.

Will try to get phone no. for stevie.Thanks again.

Pomeo
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #5
Can someone explain why P&W£R£L£A goes to #########
and Portland remains Portland?
Anyone know where P£W£R£L£A went?
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #10
ah well, that's the price you guys have to pay for that lovely 6 pot noise :D
Niall You mean you never read my question and quoted for a twinnie..Wonder if he'll price match....

Thanks wrinks I suspected something up...Their web page strange.


Crispdust...I think the same MAf is used in a VW.....But after going round in circles to get a battery and gor a Merc one I'll not confuse the electronics and fit a genuine Bosch

Thanks Guys.
Pomeo
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #12
Hi charlee Can you advise where you got it.
Thanks Pomeo
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #14
I got it in Croatia.
Silly me:D :eek:

I saw your base was croatia.

Maybe if my son asks big dada purso nicely tomorrow he may bring me back one after he visits back home.

I once asked a guy where he got his tyres from .He replied India....They were india tyres....I told him Ive got Uniroyals BUT they have never been to Univeristy or met the Queen.

:lol: :lol: :lol:
P
 

·
Registered
Joined
·
1,549 Posts
Bust I think.

wrinx

Oh dear, what a pity, never mind :D






Actually, despite them spamming the forum ages back, they always seemed to stock some interesting lines for the 166 - much more range than most tuning websites :(
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #16
Yes HowardA a lot of their stuff was good and was genuine alfa.

Cheaper than Halfords and Alfa dealers.

Got my tensioner and belt their on a deal 2 years ago...Their original oil filters were a steal at the price they were selling them.


Alfa Romeo (Dot Com ) are losing a lot of trade due to their inflated prices.If the wee guy can do it there is absolutely no reason why they can't.

Pomeo
 

·
Registered
Joined
·
10,915 Posts
Discussion Starter #17 (Edited)
Well I'll be MAF'd

New maf arrived and decided to fit in the 3 litre 1.

The old sensor from it was put in 2.5 one.

Changed the whole tube.

BIG MISTAKE..(not really)

FIRST/First the top of the air filter cover came off easier than I expected..BUT...it was the metal inserts which came out of the the base.

SECOND/Then the nuts which I cleaned with awire brush n sprayed with WD40 " came off easy the last turned in the holder.
Got mole wrench n held stud and slackened nut off enough to prise the metal bracket up enough to get the old tube out.

THIRD/ Then the Alfa clip which came off so easy was a nightmare to put back on .No wonder they are replaced with jubilee clips...Must be a nack to it.


Fourth....Tested it hit kickdown and almost lost my breath...What a change in a car.Will need to get another one for the 2.5 now.

Anyone know an easy way with the clips ,inserts and/or nuts which hold MAF.

Or does everyone stick it in a garage?

(Now know why portland onlt sell the sensors).

Pomeo
 

·
Registered
Joined
·
2,220 Posts
You can get the security torx bolt remover from Machine Mart6 of similar. Cheap, unless its the 5 star one and not 6. alternatively a plumbers adjustable wrench for doing compression joints is useful on the edges of the self tappers. You can also use these for the Afla pipe clips - yes there is a knack. I can do it VERY easily now, even with an ordinary pair of pliers.
 
1 - 20 of 48 Posts
Top