Alfa Romeo Forum banner

1 - 17 of 17 Posts
W

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Can anyone tell me what order the relays are in on the bulkhead? From the owners handbook the fuses are

3A=lambda probe fuse
15A=fuel pump fuse
7.5A=????? (this one is the lambda fuse on the 16v's!!)

Then the three relays are

-fuel pump relay (I gues the one behind the fuel pump fuse?)
-Services relay (???)
-Main relay (???)

Had the injector light on all the time today after fixing a screen washer pump leak yesterday. Went to investigate and found the 7.5A fuse was nakkered but no idea what it controls!!

Replaced it and the injector light went away only to return later on. Checked around again and decided to swap the relays about...its gone out now :rant:

Anyone know what the 7.5A fuse is?

wrinx
 

·
Registered
Joined
·
4,651 Posts
It could be for the Lambda sensor but maybe the heating circuit as opposed to the settings.................Someone started posting quite a bit regarding the fuses relays your on about a while back

Just for the life of can`t rememeber who

Try searching a few of the oldish threads ...............if you canb get the search to work :rolleyes:

I tried last night .........even used the title of the thread and it could`nt find it :confused: so i scrolled back in time and there it was :confused:
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Wasn't it Chris155???

Heated circuit kinda makes sense but the injector light was still there after I changed the 7.5A fuse :confused:

wrinx
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #6
speed freak said:
Maybe your sensor`s gubbed as well ;) :D
............always wid da negative waves Moriarty, alwasy wid da negative waves :p (Donald Sutherland)

wrinx
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Ok, so that explains the 7.5 as lambda, so whats the 3A described as the lambda in the handbook???

I guess the fuse on mine had gone AND the relay was playing up :rolleyes:...doh!

wrinx
 

·
Registered
Joined
·
4,651 Posts
wrinx said:
............always wid da negative waves Moriarty, alwasy wid da negative waves :p (Donald Sutherland)

wrinx
From Kelly`s Heroe`s :D :D (i got one)

The 3 amp is probably for the signal`s to and from the Ecu :rolleyes: ;)
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Yup, makes sense ;)

Love that film, Mr Sutherland turns it into something interesting :D

wrinx
 

·
Registered
Joined
·
2,778 Posts
speed freak said:
Indeed, 'twas I....it's my favourite topic :)


I'm pretty sure they are; ECU main power, Lambda heater, Fuel pump and I think it's 30A, not 3A isn't it????? (or was that 10A.......)

The signal from the lambda goes direct to the ECU though - it's a very high impedance signal so doesn't need a fuse.

And fuse trouble followed by relay trouble is one I had as well - I'm sure the heat rising from the rear manifold is a problem for those parts. So is vibration if the wire connected to the IAC is routed badly......like it was on mine.
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #11
Chris, you'll be pleased to know you were right all along...for the first time in over 18months the injector light hasn't come on going up the hill it usually lights up on every day without fail :D:D:D

wrinx
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #12
So you'll be expecting better fuel consumption then ???
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #13
Oooh, hadn't thought about that...I'm just glad the christmas tree dash has gone :D Thermostat needs doing I think so eventually consumption should improve.

wrinx
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #14
Stats don't seem to last long :(
I replaced mine just after I bought the car (just over 2 years ago). It sat at just under 90ºC till recently. It now sits at 80ºC and won't get any higher. The cooling fan never kicks in, even if idling for ages and the heater ain't as hot as I remember. Another £15 then. Boo hoo..........
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #16
From the Alfa dealer in Gorgie Edinburgh (Arnold Clark). It was about £15 or £16.
 

·
Registered
Joined
·
2,778 Posts
Nice one Wrinx - just happy you found the gremlin. Symptoms certainly sound just like mine was. Made MOT tests interesting and no mistake.

Marlon - the mpg is a little better on average doing the typical short journeys but lots better on a run. Replacing the stat certainly helped push it in the right direction after fixing the Lambda heater problems.
 
1 - 17 of 17 Posts
Top