Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
USB & Blue& Me stopped working Mileage counter flashing car pulling to the right

Hello All,

I'm looking for some advice. I took my car into a garage to a blower/heater fix. It took them 4.5 days loads of hassle and when they returned my car the steering wheel was so far off centre it looked like I was turning left when the car was driving straight. At first they said they never touched the steering for this fix but later on they reckoned they took the steering off to do the blower/heater job and it wouldn't go back on the column correctly, how is this possible seems weird to me and why take a steering wheel off when fixing the blower.

However since they messed with the steering wheel my car pulls to the right. Tracking is fine and wheel are aligned, however, the dodgy garage instead of fixing the problem let my left tyre down to PSI 23 and kept my right tyre at 30 psi. I noticed it was a bit flat when pumped back up car starts pulling to the right again.

1 week ago I was driving along and the odometer starts flashing and instantly the blue&me stopped working as so did my USB, so it won't charge my phone up and the windows button no loner works and nor does the handsfree. Also my start stop won't work.

Anyone know what this could be or how it can be fixed? Anyone know why my steering wheel was off centre, the garage finally got the steering wheel back to centre but the car has been pulling right ever since.

Wish I'd never taken it there as the car was running amazingly before it went into this dodgy garage. Tracking is spot on and so it wheel alignment as I have had them independently checked.

Odometer just keep flashing now continuously and the the features above have not worked in over a week. HELP!!!
 
I

·
Guest
Joined
·
0 Posts
Hello All,

I'm looking for some advice. I took my car into a garage to a blower/heater fix. It took them 4.5 days loads of hassle and when they returned my car the steering wheel was so far off centre it looked like I was turning left when the car was driving straight. At first they said they never touched the steering for this fix but later on they reckoned they took the steering off to do the blower/heater job and it wouldn't go back on the column correctly, how is this possible seems weird to me and why take a steering wheel off when fixing the blower.

However since they messed with the steering wheel my car pulls to the right. Tracking is fine and wheel are aligned, however, the dodgy garage instead of fixing the problem let my left tyre down to PSI 23 and kept my right tyre at 30 psi. I noticed it was a bit flat when pumped back up car starts pulling to the right again.

1 week ago I was driving along and the odometer starts flashing and instantly the blue&me stopped working as so did my USB, so it won't charge my phone up and the windows button no loner works and nor does the handsfree. Also my start stop won't work.

Anyone know what this could be or how it can be fixed? Anyone know why my steering wheel was off centre, the garage finally got the steering wheel back to centre but the car has been pulling right ever since.

Wish I'd never taken it there as the car was running amazingly before it went into this dodgy garage. Tracking is spot on and so it wheel alignment as I have had them independently checked.

Odometer just keep flashing now continuously and the the features above have not worked in over a week. HELP!!!
What a terrible garage, letting on tyre down to 23psi is just dangerous, report them to trading standards.

It made my mind up that i will get my service done a Meridan Milano
 

·
Registered
Joined
·
47 Posts
what garage did you get it done at by the way? - Mine is in at the moment having similar job done (Heater/blower replaced).. been in all week... they even had to take the doors off! - hoping to get mine back early next week... I will watch out for, and hope that I don't get any similar issues!

If its faulty from the work done then I would be inclined to take it back - ask to speak to the manager and insist the issues are sorted out as it would seem they are caused by the poor work done.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
The garage was 'platts' I've reported it to Alfa and opened a case with them about it. Not sure what will happen but I'm so annoyed.

I normally go to Mangoletsi but they couldn't fit me in for 2 weeks and my blower completely stopped. Any ideas why they'd need to take the steering wheel off? Has anyone else's odometer flashed continuously before?
 

·
Registered
Joined
·
49 Posts
The garage was 'platts' I've reported it to Alfa and opened a case with them about it. Not sure what will happen but I'm so annoyed.

I normally go to Mangoletsi but they couldn't fit me in for 2 weeks and my blower completely stopped. Any ideas why they'd need to take the steering wheel off? Has anyone else's odometer flashed continuously before?
A flashing odometer usually means that the Blue&me control unit needs replacing.
 

·
Registered
Joined
·
89 Posts
Don't know about the G - but in my 147 and 159 flashing Odometer meant it needed a proxy alignment. Usually required after a Canbus component has been removed/replaced - 5 minute job for a garage or you can do it yourself with OBD and MultiECUScan (registered version)
 

·
Registered
Joined
·
2 Posts
Probably too late now but as an alternative to Platts & Mangoletsi you could try HRG at Sandbach. Independent Alfa specialists way cheaper & (IMO) way better than local main dealers. I've been taking various Alfa's to them for over ten years & I am always delighted by the service I receive there.
 

·
Registered
Joined
·
1,794 Posts
Don't know about the G - but in my 147 and 159 flashing Odometer meant it needed a proxy alignment. Usually required after a Canbus component has been removed/replaced - 5 minute job for a garage or you can do it yourself with OBD and MultiECUScan (registered version)
My view as well - although the cause will likely need to fixed first (something not connected correctly or has becomes disconnected perhaps).
 
1 - 9 of 9 Posts
Top