Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter #1
Hi all,

I opened the window all the way, and there was a kind of click and grating sound. I tried to wind it back up and got the same grating sound but no movement. I've got the door card completely off but there doesn't seem to be any way of viewing what might be going on. I understand I might need a new window regulator (it's an autodrop so not cheap) but wondered if there's anything else it might be and any way I might be able to view. Is there another part of the door panel that comes off?

The urgent bit is I need to go out, it's gonna rain and I won't be able to work on it until next weekend at the earliest. Is there any way to force the window up? I've tried using my hands, and using the motor at the same time, but it won't budge. It feels like it's stuck on something but I can't see inside enough to find out.

Thanks in advance for any help you can give
 

·
Registered
Joined
·
334 Posts
U should be able to get a little mirror to see whats happening .Can u get to the bolts that holds the drop glass to winder ? Can u take a pic now trim is off
 

·
Registered
Joined
·
4,627 Posts
Possibility that the autodrop microswitch has failed.

Look on the door panel near the hole towards the front and you should see a connector like this

http://i1134.photobucket.com/albums...er door skin/2012-04-21_16-12-44_DSC_0073.jpg

( yours should be clipped to the metal ).

Disconnect the connector and look inside the longer part. You'll see two pins. With a bit of wire ( maybe even an unpainted paperclip ) short the two pins together. With the two pins shorted, try lifting the window with the switch.

EDIT : eventually the autodrop process will timeout and you can lift the window using the switch, BUT the problem will happen every time the door is opened. With those pins shorted the autodrop system is bypassed ( the window will not autodrop ) which will give you time to sort the problem properly.

EDIT 2 : Just to be clear. DO NOT try shorting the pins in this half of the connector -
http://i1134.photobucket.com/albums...p regulators/2012-04-05_10-12-56_DSC_0011.jpg
you need to short the pins in the OTHER half of the connector.
 

·
Registered
Joined
·
286 Posts
Discussion Starter #6
U should be able to get a little mirror to see whats happening .Can u get to the bolts that holds the drop glass to winder ? Can u take a pic now trim is off
I tried some pics but they haven't come out very well. I just put loads of force into trying to move it and managed to get it to budge, once it's about half way up the motor starts to bite and takes the window the rest of the way. I then wound it down about half way and up again, that was ok. Thinking it might have fixed itself I took it all the way down and it got stuck again so I forced it up.

So currently it works as long as you don't take it down more than half way. The mechanism sounds like it's slipping a little on the way up but sounds fine on the way down.

I have to go out now but if anyone has any further suggestions if it might be anything else apart from needing a new regulator let me know.
 

·
Registered
Joined
·
334 Posts
Maybe the teeth are worn on the winder mech .You need to get it out to have a look .Gravity and the weight of the window helps it out on the way down
 
1 - 8 of 8 Posts
Top