Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I know that i don't visit the site very often, mainly cos never really had any major faults requiring the need to rack everyones brains for a solution. Most problems encountered were solved just by reading posted threads.
Anyway, just to say i've traded the beloved 156 1.8 TS for a newer 147 2.0 Lusso. (Obviously the same TS engine with undoubtedly the same problems to encounter). So far, more economical than the old 156 and more reliable.
The wife's instructions were that if i fancied changing the car, then would i please find a smaller one preferably with a hatch.
Instruction followed to the letter! (a) 147's are smaller in size to a 156, and (b) it's a hatch. Ok so it's another Alfa which i must admit are in my opinion "pretty good" and the engine size is just a little bigger.
It's done less than half of the mileage of my old 156 which had done 134,000 miles when i traded it and the 147 has only 56,000 on it with the cambelt having just been replaced.
Any comments from 147 owner/drivers would be appreciated as per usual, oddities only come to light by asking people who actually own one.
Thanks.
 

·
Registered
Joined
·
4,924 Posts
The only problems i have had so far are suspension knocks and airbag lights. Not let me down yet.

Fantastic car, Fantastic engine and fantastic interior!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thanks to all for comments. Will keep an eye on those brake discs for warping and also have the rattle sorted out from what sounds like the exhaust when not fitted securely.

Cheers.
 
1 - 5 of 5 Posts
Top