Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

I have been searching the web for weeks now and I'm unable to find an update for my Alfa Romeo Mito Uconnect 5 sat nav.

When I go on the uconnect website it ask's for my VIN number I put that in and nothing happens.

Can anyone help please?

Thanks in advance.

Michael Geary
 

·
Registered
Joined
·
11 Posts
Hi All,

I have been searching the web for weeks now and I'm unable to find an update for my Alfa Romeo Mito Uconnect 5 sat nav.

When I go on the uconnect website it ask's for my VIN number I put that in and nothing happens.

Can anyone help please?

Thanks in advance.

Michael Geary
Same happened here. Then the email contact on the site only works if you are in US. All a bit daft.
 

·
Registered
Joined
·
5 Posts

·
Registered
Joined
·
4 Posts
Thank you BobbyBoxMiTo for posting the update it fixed my 2015 Giulietta. I would pair with my phone but I had no voice recognition and the text could not be read out aloud. Mine was a uconnect 5" no SatNav . For anyone that want to know the Uconnect 5" without satnav completely relies on the voice recognition of your pair device. Thank you for posting the update on this forum , text reading and voice recognition now work great :) . Thank you BobbyBoxMiTo for posting the update. Shame on the Alfa dealers, the only question they could answer was, if it relied on the phone for voice recognition. Any answers I got were very speculative. I must have phoned 15 dealers over the UK not one had a clue on how to fix it. So my experience was I downloaded VP2_CO_13.00.74.00.zip, unzipped it to a FAT 32 formatted 16GB USB stick. Plugged the Usb stick into the car and it came up with an error code. I read somewhere that a user said the version installed in the firmware in my car maybe too old. I went into the engineering menu on my car and got the installed version, it was 05.xx.xx.xx way to old. What i didn't tell the dealers when I was phoning around was my occupation. I'm a software engineer, have been for over 30 years. I didn't say because they might think I was being a smart arse, so I knew any answers I received were, lets says not based in fact. Anyway, regarding versions, first of all the car told me my version 05.xx.xx.xx was created in 2008 despite the fact my Giulietta is 2015. Regarding version the last 2 numbers are a bug fix. The next two mean features have been added to the software or breaking changes . The first 2 numbers mean a major rewrite . This means between 2008 and the latest version there have been 8 major changes to the software !!. So my next step was to wipe my usb stick and unzip a previous version VP2_CO_13.00.57.05.zip on to it. The upgrade then took about 30 mins screen went off a few time a little concerning but, when the upgrade had finished all working perfectly. Thank you everyone on this forum for achieving what the Alfa dealers could not :)
 

·
Registered
Joined
·
6 Posts
Had a 99% success with this. Updated my 2016 facelift Mito radio to version 13.00.57.05 everything works except now I have no apps efficient drive,twitter,deezer ect. Are there any settings I need to change to re-enable them or are they downloadable from anywhere



T.I.A
 

·
Registered
Joined
·
4 Posts
Sorry I wish I could help in that regard as I don't have those Apps on my uconnect. Did you use the VP2_CO_13.00.57.05.zip, the co is for European cars
 
1 - 8 of 8 Posts
Top