Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Hi guys wondered if somebody could tell me ive got a noise sounds like worn brake pads coming from the front, but they are new discs and pads have had calipers and bearings checked both fine, is it possible it could be tyres causing the noise more evident at around 20mph when braking the tyres are about 2 years old and just above the wear limit mark

regards Paul
 

·
Registered
Joined
·
144 Posts
It will be most likely your tyres that are making the noise. My car with 17" wheels is terrible at around 20 mph, especially when braking. people have tried changing tyre manufacturers to see if it cures the problem, but i have come to live with it. I think it does get worse as the tyre wears, this is probebly down to the compound hardening with age and irregularities of wear. Hope this helps. Dave
 

·
Registered
Joined
·
164 Posts
I had the same problem with my Rover 75; it depended on the road surface, sometimes the noise disappeared, Over 30 mph was always fine, finally a tyre change did the trick, the deeper tread absorbed the vibration & harmonic.
 

·
Registered
Joined
·
2,697 Posts
The Alfa tyres wear on the inside edge and get noisy towards the end of their life. Setting the tracking to Zero makes a vast improvement but can't cure worn tyres.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
Just a quick update had a couple off new tyres fitted at my local tyre shop namely Wombwell Tyres, nothing special infact £92 for both and the only thing l could hear driving away was SILENCE yipee.
 
1 - 6 of 6 Posts
Top