Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
567 Posts
Discussion Starter #1
Been driving this car about for a couple of days now and was wondering what temp should the gauge be reading? it gets to and stays on 80 and the heater not so good, air con is nice and cold though (by rough comparison my spider stays around the 90 mark and has a pretty decent heater).
 

·
Registered
Joined
·
9,218 Posts
Our NA is always on 90 so you might have a thermostat that is stuck open and not warming up properly .. which may also explain the poor heater.
 

·
Registered
Joined
·
155 Posts
I agree with the above, it should sit pretty much bang on 90 / horizontal.

Although the gauge itself is very highly damped and not entirely accurate. It might be worth having a look on an obd2 reader and seeing what the actual coolant temperature is. If it's only showing 80 on the gauge the real temp could be well under that.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #4
It is due a service in March, so I will ask them to check that while it's there.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #5
There were signs of a previous coolant leak around the thermostat housing, along with slightly low coolant level. To be monitored for further leakage/coolant loss, which in turn will decide how soon any needed replacement takes place.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #6
Been out and about a bit more today and the temp actually rose to 90 a couple of times but returning to 80 again afterwards, at least I know the needle does go higher than 80 on the gauge.
 

·
Registered
Joined
·
155 Posts
Sounds like your thermostat is getting a bit lazy, they do tend to get less accurate over time, not closing fully, not opening fully and slower to react to temperature changes.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #8
Its still early days given the amount of downtime during lockdown, as I'm monitoring the coolant for loss/leakage anyway replacing the thermostat may just be the answer to both issues.
 

·
Registered
Joined
·
24 Posts
On my 1.4 155 the dash gauge shows 90, but the diagnostics says 70. Then the car continue to heat up till 79-81 but the gauge do not move more. When the gauge was showing less than 90, I had thermostat that was not working correctly.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #10
At the moment with the infrequent usage, it looks like a battery replacement is next on the to-do list. Last two mornings have been local errands, I've had lazy starting followed by check airbag (which goes away on its own) and some random wiper action. Got it on a smart charger today which says its okay. Could do with a decent run somewhere to eliminate a few gremlins. On the diagnostics front I take it this is DIY as opposed to main dealer, not been brave enough to venture down that road myself as I'm bound to do more harm than good interfering with stuff I know nothing about.
 

·
Registered
Joined
·
5,819 Posts
On my 1.4 155 the dash gauge shows 90, but the diagnostics says 70. Then the car continue to heat up till 79-81 but the gauge do not move more. When the gauge was showing less than 90, I had thermostat that was not working correctly.
If it is the same as my Giulietta the dash gauge is showing engine (coolant) temperature whilst using a dongle I can get radiator temperature as well, that is often lower than the gauge indication unless the car is thoroughly warmed.
 

·
Registered
Joined
·
567 Posts
Discussion Starter #12
Took the car out for an extended "A" road run yesterday, to put a decent charge in the new battery and "blow away any cobwebs" just over two hours and 80 odd miles. Saw the occasional 90 on the gauge but would say it spent most of the time showing 80 degs. I had a dongle (TT curfer) in the obd port to see if it would collect any other readings of interest. That did show coolant temp of 61 but as this was the first time using it, may have been the temp at switching off as opposed to an average. I'll check that particular screen some more whilst out and about, now that I know it's there.
 
1 - 12 of 12 Posts
Top