Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29,280 Posts
Discussion Starter #1
I keep hearing a "twanging" noise from under the front of my facelift 156 - sounds like under the engine toward the right hand suspension. it doesn't happen that often - just when i go over certain types of bumps. i used to hear it very occasionally but has been happening a lot more since the suspension took a good whack on a big pothole last week

the best way to describe it is it sounds as if a rubber bouncy ball has hit the underneath of the car:confused:

anyone come across this before or know what it might be?
 

·
Registered
Joined
·
3,806 Posts
Ages ago there was discussion about twanging springs that weren't quite seated properly. Maybe? Dunno.
 

·
Registered
Joined
·
218 Posts
yes - exactly the same thing happened on my 2001 156. Kwick fit wanted to sell me new shocks but my local garage sorted it out with a couple of cable ties. Apparently the engine guard that sits underneath the engine had a crack & one part of it had dropped. Every time I went over a speed bump I got exactly the same noise you described. Hope this helps
 

·
Registered
Joined
·
29,280 Posts
Discussion Starter #5
yes - exactly the same thing happened on my 2001 156. Kwick fit wanted to sell me new shocks but my local garage sorted it out with a couple of cable ties. Apparently the engine guard that sits underneath the engine had a crack & one part of it had dropped. Every time I went over a speed bump I got exactly the same noise you described. Hope this helps
cheers julian, it certainly sounds like it could be that - particularly as the guard has had plenty of scrapes in it's time. gonna jack it up at the weekend and have a look
 

·
Registered
Joined
·
30,126 Posts
Mine does it sometimes, like when it's been left over a weekend and it's been damp. It does it once on a roundabout about 1/4 mile from where I live and is OK after that :confused:

Cheers,
 
1 - 6 of 6 Posts
Top