Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,209 Posts
Discussion Starter #1
Hi guys, my 156 jtdm sport 2005 has been sat for abut three months and the battery had gone flat, i took the battery out and charged it and now when turn the key and nothing happens, the interior lights come on when i open the door but no radio, no dial lights nothing?

one of the connectors is poor the one with all the little fuses attached so thinking this is causing it, would a poor battery connector cause a issue like this, i have tried many times to re attach it but still nothing happens, before i buy a replacement (the one below) i have check all the fuses under foot well and fine and also fuses next to battery

http://www.ebay.co.uk/itm/222038525678?_trksid=p2055119.m1438.l2649&ssPageName=STRK:MEBIDX:IT

is there anything else i could have done?


thanks Jon
 

·
Registered
Joined
·
9,561 Posts
If the battery has been flat for some time, it could well be dead, despite your charging. Ideally try a known good battery on it, or connect it via good jump leads (with key out of the ignition) to a good battery, then try again. Checking the earth, to the chassis and from chassis to gearbox, is also a sound idea.
 

·
Registered
Joined
·
3,209 Posts
Discussion Starter #4
Thanks guys, the earth is the big thick black one? Were does it go I have tried following it but seem to disappear down behind the engine, going to have another attempt tonight and jack the car up, ok cool that's a good idea as it will rule out the battery I will swap over the battery tonight with my daily driver car battery and see if that does it.

:thumbup:
 

·
Registered
Joined
·
3,209 Posts
Discussion Starter #6
Battery was fine

I replaced the part above and all working perfect for anyone who has a similar problem

It was the connector in pic that wasn't connecting properly

Anyone got Any tips on freeing up brakes, car sat for 3 months and are now shocking!!
 

·
Registered
Joined
·
2,271 Posts
The discs and pads should recover with use. If the pistons are sticking however it's probably time for a new caliper. Try taking it all apart, wire brushing, copper greasing, cleaning sliders etc.
 
1 - 8 of 8 Posts
Top