Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
I have a Cam error on the traction Control and can't turn it on, its off and the orange light is on all of the time.

Anyone know what units are compatible? Can I just change it for a unit from the same year with esp, I can’t seem to find any information on unit number and or compatibility.

Anyone been through this?
 
L

·
Guest
Joined
·
0 Posts
Cam error or CAN error?

CAN = 147 or GT?
Cam could be any car.

Can you get the error codes read?
 
L

·
Guest
Joined
·
0 Posts
Cam error or CAN error?

CAN = 147 or GT?
Cam could be any car.

Can you get the error codes read?
 

·
Registered
Joined
·
322 Posts
Discussion Starter #5
156 sportwagon 04 1.9jtd, Can - it been a long day!

The alfa specialist (?) who changed the cam belt on the car just before I bought it neglected to refit the breather.

It was fine for a few weeks then started to smell when the cover came off the engine, the socket was still on the clip he obviously just forgot.

Oil flooded the loom and abs unit so it all needs replacing. I have stripped cleaned all the contacts but the oil must be in the control box as there is no sign of life.

This is just one of a number of bodge related problems that didn’t surface until after a few weeks, the airbag is another nightmare.
 
L

·
Guest
Joined
·
0 Posts
the ABS system communicates on its own CAN system via the steering wheel sensor.

perhaps the steering angle sensor is defective or maybe its just that the ABS module needs some way of drying it out?

can you communicate to the ABS module? if you can its not totally dead.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #7
Yes and it is not totally dead as the ABS side works fine but its a bit over sensitive. All of the sensors have been chacked and are ok. I replaced the steering angle sensor for another reason and that made no differance.

I have checked the loom connectors, wheel sensors, the rings dont seem to have any damage... the only error is record is CAN error.
 
L

·
Guest
Joined
·
0 Posts
the CAN lines from the ABS to the steering angle [ on a 2.o JTS ] comes in down low under the glove box. it appears at the back of the steering column in a small flat connector, at the 6 o'c position.

would they have had any reason to be in around the glove box area?

how recently did this ASR light come on? 24 hours? 1 week? straight after they worked on the car?

On the ABS module is a part number, what is it? LHS of the module, iirc.
 
L

·
Guest
Joined
·
0 Posts
my JTS has the p/n 46745936 located just above the ABS connector, white Label with BOSCH ESP on it
 

·
Registered
Joined
·
322 Posts
Discussion Starter #10
Attached is the abs unit image, The question is if I find another unit, is there any cross compatibility, ie. will another esp abs unit but with a different unit number work.

As the whole thing was flooded with oil, i'm sure the probelms are limited to the unit itsself.
 

Attachments

L

·
Guest
Joined
·
0 Posts
i'd presume a replacement from another '04 1.9JTD Sw or Saloon would be the same. take note of all the numbers & compare to the donor unit.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #12
The donor is the same, if i chack the part number referances mine isnt in the list? i could just change the control unit on the front of the pump?
 
L

·
Guest
Joined
·
0 Posts
Your label is missing a set of numbers, starting with 4*******, if you wish can you send to me the last 8 digits of your chassis number , i'll tell you what part number is required.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #17
This is the error code, C1520 General fault.

The CAN data communication line (Controller Area Network) between different vehicle ECUs does not work correctly. - this i had worked out.

Bosch ABS 5.7 VDC, ISO Code: 25 86 91 01 92

Starting at the battery the connections fuses... have all been checked.

The system is turned off. i can check the abs this all works its the vdc side that is dead. Other than changing the abs vdc system i cant find a fault?
 
1 - 17 of 17 Posts
Top