Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Right so far my friends car has had this done to it:

New Thermostat
New Coils
New Plugs
New MAF
New Lamda sensors
New full wiring loom
New timing belt

Nigh on £2ks worth of work and its still broken. When you start the car it shows 'Engine motor failure' on the dash, this then goes off but re appears when driving.

I've ran totally out of ideas. Diagnostic is coming up with Lamda fault but they are brand new.

Anyone got any ideas?
 

·
Registered
Joined
·
121 Posts
Lambda's on the rear bank as well? - extremely difficult to reach. Were the lambda's replaced with new? There is a heating element in the lambda's which if it breaks will cause an error. Lambda still works when warmed up. Still, an emmisions test might be worth it to see are the lambda's doing their job.
 

·
Registered
Joined
·
9,912 Posts
Right so far my friends car has had this done to it:

New Thermostat
New Coils
New Plugs
New MAF
New Lamda sensors
New full wiring loom
New timing belt

Nigh on £2ks worth of work and its still broken. When you start the car it shows 'Engine motor failure' on the dash, this then goes off but re appears when driving.

I've ran totally out of ideas. Diagnostic is coming up with Lamda fault but they are brand new.

Anyone got any ideas?
first what diagnostics on car to warrant all this ?
 

·
Registered
Joined
·
733 Posts
I know its an obvious one...BUT, after all the work and parts fitted, were all the errors removed and ECU reset, with the diagnostic machine?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Its had numerous diag tests and resets.

Stock exhaust

All parts are OEM.

The loom is a full new OEM engine loom.

Initial problem was a buggered thermo stat and maf problem, after than was sorted a missfire started, new coils missfire remains. Timing corrected, missfire sorted. Engine motor failure light on dash, changed full engine loom due to old loom had been fixed with super glue! Then both lamda sensors have been changed as the latest diag said lamda failure.
 
1 - 10 of 10 Posts
Top