Alfa Romeo Forum banner

1 - 20 of 69 Posts

·
Registered
Joined
·
1,585 Posts
Discussion Starter #1
Has anyone managed to get the torque app on Iphone or android to work with their GT via bluetooth?

If so which protocol did you use?
 

·
Registered
Joined
·
9,204 Posts
156 won't work ... wrong interface type. Can only use a VAG-COM KKL interface cable with AlfaDiag or FiatEcuScan. Old interface spec.

147 and GT should be ok with ELM interfaces and FiatEcuScan, and VAG-COM KKL interface cable with AlfaDiag or FiatEcuScan but no idea about phone apps.


Jake: tried a search?
 

·
Registered
Joined
·
1,585 Posts
Discussion Starter #5
I've done some searching not really found much help.

I noticed in the app there is an Alfa/fiat protocol being developed still so might be a no go. Although if I select auomatically select protocol it will try to connect and you can see the dash lights and speedo do things for about a second.
 

·
Registered
Joined
·
13,685 Posts
Works OK on mine. I don't believe other than telling it to use bluetooth I chose any protocol. Are you sure the ELM device you have is compatible?
 

·
Registered
Joined
·
3,193 Posts
Yours in the 20v, so it's quite a late car and uses a canbus setup.
Works on my 2005 JTS too. Definitely not CANBUS, but I suspect it was standards compliance introduced later.

Correct, the bluetooth ODBII adaptors are ELM327 not KKL, so it won't work with the 156. Although I have no reason why it doesn't work as the ELM should work on both systems.
As far as I know, which is not far, ELM327 is the physical interface and you must then pick a logical protocol to talk over it with - KKL, which is what Torque uses.
 

·
Registered
Joined
·
1,585 Posts
Discussion Starter #15
Right I've got it working..

My Elm327 needed some modding as instructed from the FES forum...

Simply removed a 120 ohm resistor off the board and works a treat now. :)
 
1 - 20 of 69 Posts
Top