Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My Mito 174 bhp QV has had Throttle & gearbox issues since i bought it it is a 64 plate stll under warranty7500 miles only. Great car when it's warm but a alien when its cold. It will stall on start up throttle & gearbox very unresponsive. going in for a ECU update in a weeks time i am hoping that cures it if not it could be goodbye i will be very sad to see it go but is driving me mad at the moment & i dont know if i could trust it when the warranty runs out
 

·
Registered
Joined
·
834 Posts
My Mito 174 bhp QV has had Throttle & gearbox issues since i bought it it is a 64 plate stll under warranty7500 miles only. Great car when it's warm but a alien when its cold. It will stall on start up throttle & gearbox very unresponsive. going in for a ECU update in a weeks time i am hoping that cures it if not it could be goodbye i will be very sad to see it go but is driving me mad at the moment & i dont know if i could trust it when the warranty runs out
Hi, this is interesting. I have the exact same issue on an intermittent basis (also 170QV, 64 plate). Sometimes the car will stall 3 times in a row when trying to move forwards or reverse after start-up, and be slightly juddery for the next minute or so. I actually took the car in but they said there was nothing they could do unless they could replicate the fault - which they couldn't in the time the had the car.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Hi, this is interesting. I have the exact same issue on an intermittent basis (also 170QV, 64 plate). Sometimes the car will stall 3 times in a row when trying to move forwards or reverse after start-up, and be slightly juddery for the next minute or so. I actually took the car in but they said there was nothing they could do unless they could replicate the fault - which they couldn't in the time the had the car.
hi there is a update now for this but i did have to threaten the dealer a lot to get their attention . i would go back to yours and tell them. mine is mortorvouge in bedford.
 

·
Registered
Joined
·
834 Posts
hi there is a update now for this but i did have to threaten the dealer a lot to get their attention . i would go back to yours and tell them. mine is mortorvouge in bedford.
Great, thanks for the info. I'll get on to them.
 

·
Registered
Joined
·
44 Posts
I was told by Alfa Customer Service that a software update has just been made available to dealers. They said in week 22 (whatever that means). It's going in for update at end of June.

My TCT stalls when first started if outside temp is 2 or 3 degrees. On restart the revs then shoot right up.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I had the update done last week on the 9/6 seems ok so far but wont really know until the colder weather arrives i will keep you all posted. It still is reluctant to change gear when its cold but i think that is one of those Alfa things on the TCT gear box you have to put up with. After coming from a A1black edition with the S tronic gear box i am a little dissapointed but i will keep the car for a while .
 

·
Registered
Joined
·
44 Posts
When it's cold, the TCT box feels like it's been made and put together by a couple of six year olds with a hammer and a few bits of wood, very clunky & slow. But when it's warmed up I think its awesome so i can live with the initial clunkiness.

It is normal for cars to have a warm up period. I still remember having cars with 'manual choke'.
 
1 - 7 of 7 Posts
Top