Alfa Romeo Forum banner

1 - 20 of 93 Posts

·
Registered
Joined
·
4,755 Posts
Discussion Starter #1
Hi all, having had the G for a couple of weeks and starting to find some interesting things, for example you cannot select the dynamic mode with the wipers on, or that the turbo display for dynamic mode won't work with the radio repeater ( ie radio display repeated in the instrument cluster) on.
Any other tips, tricks or secrets that make owning a Giulietta that little bit better?


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
497 Posts
or that the turbo display for dynamic mode won't work with the radio repeater ( ie radio display repeated in the instrument cluster) on.



Sent from AutoGuide.com Free App
If you mean what I think you mean, e.g. boost gage disappears if the radios on, you can turn this off in the menu so it always shows. Cant remember the option off the top of my head. It did my head in for close to a year before I accidentally turned it off!! Edit: I think its under 'First Page' or 'See Radio' on the menu.

Not going into D when wipers are on is odd though, sounds like a weird fault or a software problem?
 

·
Registered
Joined
·
98 Posts
you should be able to select dynamic with the wipers on, i would get that check as like maketeanotwar said it could be a software fault
 
T

·
Guest
Joined
·
0 Posts
I can activate 'D' with my wipers on - I've been doing it all week. Sounds like a possible fault?
 

·
Registered
Joined
·
38,319 Posts
Not going into D when wipers are on is odd though, sounds like a weird fault or a software problem?

you should be able to select dynamic with the wipers on, i would get that check as like maketeanotwar said it could be a software fault
I can activate 'D' with my wipers on - I've been doing it all week. Sounds like a possible fault?
:lol:

I think/hope that was meant to be a jokey example....
 

·
Administrator
Joined
·
86,829 Posts

·
Registered
Joined
·
1,769 Posts
Probably it's speed related, not wipers. I think it's over 110 km/h when you cannot activate 'D'.
 

·
Registered
Joined
·
1,221 Posts
Although it writes 6.7 lt/ 100 km in city at tech specs.. My fuel consumption is around 14 lt/ 100 kms.. This is a great secret of Alfa Romeo brand...
 

·
Registered
Joined
·
1,769 Posts
The test is standarised and they give the consumption according to the standard. It's the standard that is wrong, not Alfa :).
 

·
Registered
Joined
·
57 Posts
Id love there to be a secret way of showing the digital speedo in the centre display all the time instead of just in all weather mode.
 

·
Registered
Joined
·
4,755 Posts
Discussion Starter #13
Ha, maybe I just slowed down with the wipers off! :) would make sense. I just thought it was some safety thing that they didn't want you having the car in dynamic when there are potentially unsafe conditions, which would make sense


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
428 Posts
Put car in 1st and switch from N to D but leave it pressed on D for 10 sec and traction control should switch off. I have GQV with old factory ecu software so not sure if it will work with the upgraded new update.
 

·
Registered
Joined
·
8,786 Posts
Put car in 1st and switch from N to D but leave it pressed on D for 10 sec and traction control should switch off. I have GQV with old factory ecu software so not sure if it will work with the upgraded new update.
ooh, will try that once the weather is a bit better....


Is the launch control thing for TCT in the manual now? it isn't in mine but it works with loads of wheelspin.
 

·
Premium Member
Joined
·
5,374 Posts
How about hitting the lock button on the remote a couple of times in quick succession to double lock the car?

Long press on remote 'open' to bring all the windows down or 'lock' to bring all windows up - but it doesn't do the sunroof as far as I am aware!
 

·
Registered
Joined
·
1,769 Posts
Actually it's not "a coupe of times", but exactly two and it's stated in the manual.

I think the windows "trick" is mentioned also.
 
1 - 20 of 93 Posts
Top