Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
hey lads
i drive a 01 t spark with a 06 engine and has no t belt cover and its way differant than the older one ...so would any one have one laying around ...searched all this side of country and can any amount of the older ones ...any ideas please cause i hate driving it without the cover .....thanks
 

·
Registered
Joined
·
6 Posts
hey lads
i drive a 01 t spark with a 06 engine and has no t belt cover and its way differant than the older one ...so would any one have one laying around ...searched all this side of country and can any amount of the older ones ...any ideas please cause i hate driving it without the cover .....thanks
Give me a photo of this cover.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
and wait till i tell ye ....a little bird told me thats a feckin 2.0 litre engine ya have there ..hmmmmmm
 

·
Registered
Joined
·
14 Posts
You've got balance shaft belt in your Beauty. It is only in 2,0TS engines. That's why your TB cover is different than in 1,6/1,8TS.
BTW: I was that little bird :D
Greetings - Arthur
 

·
Registered
Joined
·
731 Posts
I've one of those somewhere, from a 146ti. Looks the same ... I'll have a look and see if I can root it out
 

·
Registered
Joined
·
6 Posts
Sorry for late reply. It's from 2.0 ts with balancing belt, as it was said before. You have to be careful, this cover might be different in CF1,CF2,CF3 engines, but I'm not sure about that.
 

·
Registered
Joined
·
731 Posts
Sorry paulcof, I cant find that cover anywhere. There's one more place it could be but I cant check there until Sunday.........
 

·
Registered
Joined
·
14 Posts

·
Registered
Joined
·
8,918 Posts
1 - 17 of 17 Posts
Top