Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
Over the past few months, I have intermittently received the "low battery charge" warning, it's not regular, I could leave my car standing for ages and it starts fine and even other times I could drive it for 100 miles one day, and the next morning it'll give me that error, but it doesn't stay on or anything (unless it isn't meant to?) I had the battery tested and I cannot remember the exact figure but the guy who did it at Halfords with his meter said there were no problems with it that he could see, to warrant replacing the battery.

It's only gone flat on me once when I was changing bulbs and listening to stereo at the same time and then when I tried to start it, it was totally flat, though since then, I have disabled all interior lights from coming on thinking that'd prevent that happening or something, I dunno.

But anyway, it's still on the original alfa battery from new I reckon (6 years ago).

The only reason I bring this up though, is all Exide Premium car batteries are 33% off at Makro starting June 17th to June 30th, this is the second time this offer has come on and looks very good value for money

The Exide Premium 770 (77aH 760 A(EN) 12v will go down to £53.59 (exc vat.) It has that display as well telling you what color thingy the battery condition is in.

Does it sound like I could do with a new battery? and would does that offer sound decent enough? When I looked into getting one about a month ago, places like Kwik Fit quoted the same price but for like a bog stadard one etc.
 

·
Registered
Joined
·
725 Posts
Does sound suspect with just listening to the stereo making it go flat..

What are the connections to it like? Might be worthwhile checking those are are clean and tight
 
1 - 2 of 2 Posts
Top