Alfa Romeo Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
Hiya Guys

Ive got a ticking sound coming from my 2.0 phase 2 engine when its idle, sounds like its coming from the area of the cam belt? does this sound like its familiar to anyone ?

thanks
 

·
Registered
Joined
·
112 Posts
Discussion Starter #4 (Edited)
well I heard it for the first time today havign owned the car just under a month. she has been standing off for about 2 hours now, just started it and it still does it
 

·
Registered
Joined
·
112 Posts
Discussion Starter #6
Yeah it sounds really bad when its cold, but still there when its warm, Im thinking it best to get it checked out though ? Its deffinatly coming from the Cam shafts

Newbie mechanical question, but what does the variator do?
 

·
Registered
Joined
·
6,454 Posts
If it sounds like a diesel from start, its more than likely the variator, atm, I have a tappet like sound from cold and acceleration, and my mechanic has spotted an exhaust gasket on the inlet manifold is slightly blowing, so I'm hoping its that (noise goes away once warm)

I never knew they made a TS Cup GTV :confused:
 

·
Registered
Joined
·
112 Posts
Discussion Starter #8
No It doesnt sound like a diesel. Could it be cambelt cogs bearings? excuse the lack of technical wording.

They didnt make a 2.0 cup, the cup kit was factory fitted to it as an extra
 

·
Registered
Joined
·
191 Posts
i know you usually get a ticking noise from fuel injectors.

i'm no mechanic though.

tappets mebs?
 

·
Registered
Joined
·
112 Posts
Discussion Starter #10
Its deffinatly comign from the same compartment as the Cambelt, it speeds up as you rev the engine. Is this a sign of wear or one of the tensioners going maybe?
 

·
Registered
Joined
·
149 Posts
If its from the belt area it might be a dodgy tensioner. I replaced my belts few months back due to ticking noise?
 

·
Registered
Joined
·
112 Posts
Discussion Starter #13
Well I can now inform you all that it was deffiantly from the belt area

After driving it today to the local garden centre, about to leave and the engine has gone caput :mad:

AA guy put it into 4th opened the oil cap and rocked the car, the drive shaft wasnt moving hence cam belt issue.

Its now on the back of an AA van to the garage where I bought it from less than a month ago, luckily its under 1 month engine and gear box warranty.
I have a feeling that im going to have a battle on my hands with the Garage though as I get the feeling they dont like parting with cash.
 
D

·
Guest
Joined
·
0 Posts
sorry to hear that mate, hope the garage play by the rules, not to put you on a downer but check your warranty cos some take out stuff like belts, now i am worried bout mine, the belt has done 20k.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #15
sorry to hear that mate, hope the garage play by the rules, not to put you on a downer but check your warranty cos some take out stuff like belts, now i am worried bout mine, the belt has done 20k.
lol cheers for the confidence boost haha. I just spoke to the garage and the sales man said it could be pre tensioner etc so they are going to take a look at it tomorrow....so far so good!

I shouldnt think 20k is to bad, but then they can go at anytime, alfa recomendation was every 30k.
My tick only started yesterday and everything went boom today, so im thinking your long lasting tick may or may not be related
 
D

·
Guest
Joined
·
0 Posts
my tick started 2 months ago straight after an oil change, the previous owner was using thick oil to hush the variator. i am booking the car in tomorrow for a belt and variator change.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #17
my tick started 2 months ago straight after an oil change, the previous owner was using thick oil to hush the variator. i am booking the car in tomorrow for a belt and variator change.
Not a bad idea, good luck with it all
 

·
Registered
Joined
·
1,610 Posts
Sorry to hear about your problem. Hope it's all sorted out under warranty.

My 2.0TS doesn't tick, but it makes a squeeling noise in the morning when it's colde, the sound comes from the cam belt area. I give it some revs and it goes away after 5-10 seconds and doesn't come back for the rest of the day.

Was yours just ticking, or does the above sound familiar?
 
1 - 20 of 20 Posts
Top