Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Went to get the car washed, noticed there was a slight burning smell and a little bit of smoke coming from the drives side front.
Driving home heard a bang, and the power steering stopped working car was running as normal. The battery sign has come up on the head up display.

Im guessing its a tensioner or something thats gone?
 

·
Registered
Joined
·
6,985 Posts
The thud you heard was the auxiliary drive belt making its bid for freedom!

The belt drives the power steering pump & the alternator, which explains the loss of power steering & the battery light.
 

·
Registered
Joined
·
876 Posts
Assuming that you are talking about a 159 diesel, the most likely explanation is crankshaft (damper) pulley failure. This is quite common with these cars. A word of advice if this is the case: use only Dayco or genuine replacement pulleys.
 

·
Registered
Joined
·
2,160 Posts
Must be the season for it, this happened to my wife yesterday. Was a bottom pulley that had come off, £220 for a new one supplied and fitted and a good check over of the car. Very relieved it wasn't a steering rack melt down.
 

·
Registered
Joined
·
114 Posts
+1 to the above two.

Happened to me about 6months ago. (Mine's s 2.4)

Sent from my HTC One_M8 using Tapatalk
 

·
Vendor
Joined
·
46,348 Posts
Changed a couple of these in the last year. Not uncommon.
 

·
Registered
Joined
·
26 Posts
crankshaft pulley failure - happened to me too.
burning smell, loss of PS and aircon stops working.

rubber parts rubbing against each other hence creating burning smell.
quite an easy job to do. paid 150 pounds for parts.
 
1 - 8 of 8 Posts
Top