Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
So after returning from my continental road trip which lasted 3 days, consisted of 4 countries, 1500 miles and 25hrs of driving, I've gotten to know my Giulietta much better. Just a few random thoughts after the drive. :) Got the Veloce 1.6 diesel btw.

- After around the 3500 miles on the clock, accelerating became a lot smoother requiring less of a heavy right foot

- Odometer started flashing after ~2500 miles but fixed itself after ~3900miles…strange one :p

- Switching to D mode is always smile-inducing but I have noticed that besides the initial chunk of torque, there’s not much acceleration to follow. I’m putting this down to the modest 105hp from the 1.6l.

- Managed 116mph (GPS speed) on the German autobahn with relatively little effort. No unnerving vibrations or lightened steering.:thumbs:

- Found there’s a 3mph difference between GPS reading and the speedometer which is standard I guess in most cars.

- Gearbox is still a bit clunky in 1st and 2nd gear with some audible noises during the change between 1-2. Hope it's nothing too serious considering the gearbox thread I've read on here. Gears 3 through to 6 are slick though.

- Average mpg wasn’t too great (41.4mpg) compared to my typical high 50s, low 60s on my everyday commute, but that was probably because I was averaging ~86mph thanks to the autobahn! Anything above 75mph results in the mpg dropping to 35-40mpg.

- CC works just fine after getting used to the controls. V.useful on the endless, near empty straight roads in Belgium!:D

- Ride is firm thanks to the 18-inch wheels, but nothing bone shattering. I found the seats ok….but after a couple of hours the lack of lumbar support is pretty evident on my back.

- Auto-wipers functioned ok, but sometimes required an initial actuation before they worked, which kind of defeats the point of auto-wipers I thought! :p. Also noticed the rear wiper actuates in line with the frequency of the front ones in auto mode which is nice.

- Blue&Me media player is good, but now and then, it doesn’t read the USB stick and requires reinsertion. It also doesn't work when the engine is off.

- Got the standard sound system which is good enough for me. Plenty of bass, but lacks something in the mid-range. Sufficient nonetheless.

- Found the voice control pretty useless…nothing that couldn’t be done faster and more reliably with the buttons. Although I found the steering wheel buttons sometimes required a harder push to register.

- Bottle holder in the glove box is a nice touch although the bottles slide off the end if they’re not long enough (esp. when in D mode!).

- One of the plastic covers on the end of the seat guide rail came off. Just clipped it back on so no harm done.

- Did have a couple of rattles on the driver side door, but they disappeared as fast as they appeared.:thumbs:


All in all still love the car and have nothing major to complain about yet (touchwood). :cool: Managed to surprise my friends and colleagues that an Alfa can do such long trips without a single call to the RAC ;)

Just needs a well deserved wash and wax now!
 

·
Registered
Joined
·
5,473 Posts
Nice write-up, sounds like you had fun.

...just one point - if you do get an issue, call the AA - cause that's who your cover is with, not the RAC!
 

·
Registered
Joined
·
102 Posts
Discussion Starter #3
Cheers WTFH, yeah i'm covered by RAC as part of my company car contract. I guess that's who the fleet management went with.
 
1 - 3 of 3 Posts
Top