Alfa Romeo Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi there,

Recently got myself a second hand 159 diesel. One owner, 99k miles, excellent condition. ANYWAY...

A few hundred miles after buying it, I noticed slight hesitation in lower gears with a sound, I can only describe as the car is panting... After another good few hundred miles the hesitation becomes more noticeable. The turbo also whistles, a bit like a police car.

Now..I take it to the garage, explain my problem, they do diagnostics which show DPF error - so they do an engine deep clean. DPF was 98% saturated, and is now at 70...£248 later :readit: and the problem is still there. It did run a little better for about 10 minutes. I thought maybe I'll thrash it a bit. Nope. Limp mode. Towed back to the garage. Diagnostics. AH yeah its the EGR valve. Ok but I cleaned that recently. Yes but it's showing an EGR error...£177 please :teacher: . Problem is still there. Garage calls me "Its not the EGR valve, its actually the turbo" That's when I took my car back, I can't keep chucking money at various things to see if they get fixed. Had a hesitational drive home. Cleaned up the MAP sensor and now I'm writing this.

Any ideas? Also, phoned up the guy who sold me the car, he gave me £300.

Thanks! :beer: :beer:
 

·
Registered
Joined
·
168 Posts
Sounds like a useless garage, go to someone who actually knows how to diagnose properly.
 

·
Registered
Joined
·
704 Posts
Holy Mother of God......

£248 to run a forced regen on the DPF!!!!!!!!!!

That's daylight robbery.

I'd go back there with some mates and burn the place down.

Axe
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
Aghhhh :censored: Brillllliant. I'll get the molotovs together then. Just spoke to another garage who said 70% is still rubbish after a regen :devious:
 
1 - 4 of 4 Posts
Top